0

So, okay, I've been using Ubuntu 12.04 and this just came out yesterday when the launcher disappeared. I cant right click on screen 'cause nothing happens, I can open TTY with ctrl+alt F1, F2 and so on...I've been able to run a terminal with

DISPLAY=:0 gnome-terminal

And switch to it with Ctrl+alt+F7. I do this in case something goes wrong with TTY. I also can run nautilus with

sudo nautilus

I can access to my desktop and files but everything looks bad and basic, I can't access to media e.g. a usb wich I want to backup my files in. Here are the things that I already tried:

DISPLAY=:0 ccsm Which seems.to be okay, first time I went there Unity was unchecked and I checked it and clicked okay to the additional dialogs that checked another options also like OpenGL...After this, nothing happened. I rebooted like 6 times and same. Weird thing.is that when I reset to defaults the Unity option unchecks itself.

unity --reset WARNING: no DISPLAY variable set, setting it to :0 ERROR: the reset option is now deprecated

Then I run the display =0 and it just goes.with the last error.

Updating nvidia Drivers Removing nvidia Drivers Installing nvidia Drivers ReInstalling nvidia drivers Same with Compiz, Unity, Unity Desktop, and Xorg. Reseting lightdm Changing to GDM Unity Tweak Tool Reseting compiz with dfcon-tool Installing Xubuntu to have the kind of back up desktop manager...but same ..nothing. I need to say this that I think is where the problem is... whenever I open Unity from the terminal and/or TTY, it crashes; it loads the compiz (core) plugins but it stucks in:

.... compiz (core) - Info: Loading plugin: unityshell compiz (core) - Info: Starting plugin: unityshell Segmentation fault (core dumped)

There's a very limited info about this one and posts offer what I already my previous tries to solve the issue. Im sorry I cant put the complete tty info as Im posting this from my phone ...thanks in.advance!! I really need some.files and pretty much tried everything out there! :(

0

You are missing the kernel-headers package which is a dependency for the nvidia Unified Driver module to be built.

Install the kernel-headers package for your kernel version and reinstall the nvidia binary driver.

dpkg-reconfigure should sort you out with the nvidia package after installing kernel headers.

  • I tried but at some point terminal.says: Depends: linux headers 2.6.32-34:i386 but is not installable... when I try to reload my Unity says; Unity is not supported by your hardware – Alexis Iván Jul 29 '15 at 22:09
0

In this case, please install the latest available kernel and install its headers too.

That kernel you're running is TOO old ( 2010?)

Not the answer you're looking for? Browse other questions tagged or ask your own question.