I bought a Chromebook from Acer with an ARM-Architecture (ARM7 => 32bit, i think)

I want to program in Android-Studio.

So I downloaded it and tried to install, but it didn't work.

The error-message is Unable to run mksdcard SDK tool

After research i know that the problem is with 64bit-Architecture and I have to install the 32bit libs

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

I cant install these libs. I think that the reason is my ARM-Architecture.

Has anyone an idea to solve the Problem?

My operating system:

ACER ChromeBook ARM7-Ubuntu 14.04 LTS (upgraded from 12.04 LTS) installed by crouton-script

Thanks a lot and i hope you understand my problem. Sorry for my bad English. I couldn't find any solution in German or English.

  • try this command sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6 – orvi Jul 29 '15 at 12:05
  • i tried, packages error : "unable to locate package" – denny1337 Jul 29 '15 at 12:22
  • Did you use sudo apt-get update and sudo apt-get upgrade before that ? – orvi Jul 29 '15 at 12:25
  • yes, same error messages – denny1337 Jul 29 '15 at 12:30
  • Open "Software Sources" (or Software & Updates in 13.04+) by searching for it in the Dash. Open the "Ubuntu Software" tab. Ensure that the first 4 check boxes on this tab are enabled – orvi Jul 29 '15 at 12:33

I don't think this is currently possible as Android SDK is not available pre-compiled for ARM, only for x86(64) architecture. In theory, Android Studio should work as its Java, but I suspect it has native executable (.so) library dependencies as well as they would need to be recompiled for ARM as well trying to run Android Studio on a HP Chromebook 14 (Tegra K1 based) with ubuntu installed crouton and openjdk installed via apt just causes the java exe to stop - not error message or segfault, just does nothing.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.