1

This morning starts with ubuntu updates installation, which unfortunately freezes at some point. I hard-rebooted my laptop and got grub> command-line. There I tried manual boot from each of two latest linux images, but didn't succeed. I booted from USB stick instead and started boot-repair which succeeded. After reboot I got

Insert system disk in drive
Press any key when ready

Suspecting that something wrong with linux image I reboot with USB stick once again and run Boot Repair with option Purge linux images and install the latest one. Boot Repair hangs on exactly on this operation during the work. I mount my laptop's / and inspect that old images was purged but no one was installed. Then I chroot'ed to it and installed latest linux package manually through apt-get. Reboot, run Boot Repair once again (w/o purge option), it succeeds, reboot once again and got back Insert system disk in drive message. The report from last run of Boot Repair can be found here: http://paste.ubuntu.com/11958644/

Any suggestions what to do now?

1

Boot-Repair allows to easily do the EFI renaming via the "Rename Windows EFI files" option, but that option is not enabled by default because it's a dirty hack and it is not reliable in all situations. Instead, it is safer to change the UEFI boot order, when possible, or have bcd call grub, which is what Boot-Repair suggests (see the 4 last lines of your log).

  • Thank you! I was sure for some reason that this option was turned on in BR, but it fails somehow. – Artem Pelenitsyn Jul 30 '15 at 6:01
1

you could try this:

boot from a ubuntu installation live usb

and then

run boot-repair again

and use this

custom repair

and it might work fine this way.

  • Thanks but manual hacking in /EFI worked for me. – Artem Pelenitsyn Jul 29 '15 at 10:37
0

Can't believe: exactly the old dirty hack with manual renaming of EFI-files works. I wonder why Boot Repair didn't manage this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.