0

I want to be able to connect to the remote system via teamviewer even if it was restarted.

I can connect to the system if i run teamviewer manually, but can't do the same if system was restarted.

Daemon is running:

host@rtk:~$ teamviewer -info

 TeamViewer                      10.0.41499  (DEB) 

 teamviewerd status              ● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
   Active: active (running) since Вт. 2015-07-28 17:33:27 MSK; 3min 21s ago
  Process: 1077 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
 Main PID: 1056 (teamviewerd)
   CGroup: /system.slice/teamviewerd.service
           ‣ 1056 /opt/teamviewer/tv_bin/teamviewerd -d

However i can only connect system only after manual teamviewer execution:

> teamviewer

It's pretty simple to do what i want just specifying teamviewer in session startup applications. But session is protected by password, so teamviewer won't work until somebody get login to the system.

0

I think when you restart the computer at startup Teamviewer loading faster then the daemon itself, so thats why the error message: "please start daemon" bla bla bla.

My solution was that add a sleep 5 value in the /opt/teamviewer/tv_bin/script/teamviewer file. So to clarify my file looks like:

#!/bin/bash

# If you see this message, you probably attempted to start TeamViewer.
# Please open a terminal (Konsole, gnome-terminal, xterm),
# navigate to this folder (type 'cd /path/to/teamviewer' [Enter])
# then execute TeamViewer (type './teamviewer' [Enter])

sleep 5 #added line#
TV_SCRIPT_DIR="$(dirname "$(readlink -e "$0")")"
source "$TV_SCRIPT_DIR/tvw_main"

Main "$@"

Worked for me on Manjaro x64 0.8.13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.