8
$ wine --version
wine-1.7.47-161-g1a0c4ef

$ winecfg
syslog: kernel: [33279.238873] wineserver[9087]: segfault at eeb102d0 ip 00000000eeb102d0 sp 0000000052879ac0 error 14 in ld-2.19.so[7fb3eeb0f000+23000]

$ wine prog.exe
syslog: kernel: [33554.031996] wineserver[9173]: segfault at a31c12d0 ip 00000000a31c12d0 sp 00000000a4fdfbf0 error 14 in ld-2.19.so[7f37a31c0000+23000]
3
  • Have you changed anything at all in Wine or installed anything, or is it just doing this right after a fresh install?
    – Ian
    Jul 28 '15 at 14:35
  • No, it happened after today's update. Jul 28 '15 at 14:36
  • can you rollback the install?
    – Daniel
    Jul 28 '15 at 14:47
5

I booted the previous kernel (3.13.0-58-generic) and it works again. 3.13.0-59 fails for me.

2
4

Solved. Today updated the kernel (3.13.0-61), and all was fine.

3

Install newer 3.19.0-25 kernel. And wine 1.6 works again!

see this post How can I use Kernel 3.19 in 14.04 now?

sudo apt-get install linux-generic-lts-vivid

7
  • +1 I don't get the downvote. This is the solution that I chose. And it works.
    – rpsml
    Jul 29 '15 at 17:55
  • @rpsml If this answer works for you then don't forget to tick ☑ on left of this answer and up-vote it. Jul 29 '15 at 18:43
  • @mudit-kapil I did upvote the answer (hence the +1 preceeding my comment). But I did not ask the question, so I cannot accept it...
    – rpsml
    Jul 29 '15 at 18:47
  • @rpsml do it on the ^ mark left on the answer not in comments Jul 29 '15 at 18:52
  • @mudit-kapil That is exactly what I did (and then pointed out in my comment that I upvoted it).
    – rpsml
    Jul 29 '15 at 18:55
3

Running a wineserver instance manually seems to help. Run wineserver -p before trying to run a program with wine.

UPDATE: changing the working directory doesn't help reproducibly but running wineserver manually does.

7
  • No, same error: kernel: [ 110.463946] wineserver[3687]: segfault at c9f4d2d0 ip 00000000c9f4d2d0 sp 000000003053f5c0 error 14 in ld-2.19.so[7f71c9f4c000+23000] Jul 29 '15 at 3:46
  • This was confirmed to help in the launchpad ticket and also going back to the old kernel. So, maybe you have a different variation of the problem?
    – jrudolph
    Jul 29 '15 at 9:40
  • wineserver;sleep 1 is work. ps ax | grep wine 22434 ? Ss 0:00 wineserver Jul 29 '15 at 10:36
  • wineserver;sleep 1;wine prog.exe : kernel: [24528.776922] wine64-preloade[22450]: segfault at 7c872d40 ip 000000007c40000c sp 000000007c872d40 error 6 in wine64-preloader[7c400000+3000] Jul 29 '15 at 10:38
  • 1
    Have you tried using the -p flag? Otherwise, it may have already shut down again.
    – jrudolph
    Jul 29 '15 at 11:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.