4

I was recently reminded of one of the things I didn't like about nVidia cards & Linux. I've installed 3-4 of them over the years in different machines (different cards, driver versions), and every one of them did the same thing to me:

After installing the proprietary driver (the open-source is fine), the virtual consoles (1-6) no longer work. (The problem was mentioned in this question, but a permanent solution was not the asker's priority.)

Upon switching to a text console, the monitor(s) no longer receive a signal from the video card.* Pressing Ctrl-F7 brings back the X console.

*In my current configuration, 2 of the monitors shut down but the 3rd displays a text screen with

Ubuntu 15.04
 .  .  .  .

EDIT: sometimes the above message is replaced with an additional console message, like

[    0.490534] ACPI PCC probe failed.
starting version 219
_

Also interesting in the current setup is that when I switch back to #7, I usually get a dialog box "Authentication is required to update SMART data from...(/dev/sda) I'm only 90% sure this happened at the same time as the card & driver install.

I verified that /sbin/agetty processes are running for tty1-5.

Based on my own luck, I'd assume that it was a universal problem, but I sure haven't heard it discussed as if it were.

Any thoughts on how to get text consoles back without getting rid of nVidia's driver?

  • This might have relation to your monitor as well. If the monitor demands a video mode that the framebuffer driver can’t implement properly, then your text mode consoles may fail. You have a high-resolution modern monitor (LCD or LED), Ī̲ presume. Could you connect some simpler monitor (something like 1280×1024 or even CRT) to isolate this possible cause? – Incnis Mrsi Aug 15 '15 at 12:38
  • @IncnisMrsi Interesting thought -- I'm used to the idea of sending a signal that a monitor can't handle, but hadn't considered the "new monitor-talks-to-computer" world that you described. The fact that one of the monitors displays text suggests that this is not the case, though -- at least not for that monitor. (The FB driver is certainly happy to display something, though I suppose it's possible that the virtual TTY code could refuse to make use of the display for some reason.) (cont.) – Charles Boling Aug 18 '15 at 2:34
  • (cont.) It's also apparently displaying console messages. You're right; I'm currently running 3 monitors (were all 1920x1080; now one is a 1280x1024). When I'm in a position to take the machine down, I'll try it with a simple single-monitor setup. – Charles Boling Aug 18 '15 at 2:34
  • The console message led me to other similar problems, including [this one] (askubuntu.com/questions/383636/…). I found that if I held SHIFT to force the GRUB menu to appear, then X no longer worked and it instead stuck in a similar way to that reported by other people. This led me to try the nomodeset solution, which worked. – Charles Boling Aug 18 '15 at 4:36
  • Running only a single 1280x1024 monitor has no effect on the problem. – Charles Boling Aug 18 '15 at 4:56
1

Apparently, the current version of the driver on this card does not clone the console screen on all monitors, but instead displays it only on one, powering down the other two.

Adding nomodeset to the GRUB_CMDLINE_LINUX_DEFAULT parameters (so the line reads, for example, GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset") in /etc/default/grub (and then running sudo update-grub) fixed the main problem; I now have normal virtual console operation. (I also got rid of the quiet & splash options, since there was no usable splash screen anyway, only a blank screen during most of the boot process.)

(Note that this solution does not do anything to help the problem of the "Authentication is required to update SMART data..." dialog appearing most of the time after switching back to X from text.)

  • S.M.A.R.T. is a hard drive thing – A.B. Aug 18 '15 at 4:54
  • @A.B. Yes -- which is why it strike me as rather odd that switching virtual consoles to text and back to X would trigger that dialog. Since the X session still exists -- it's simply not being displayed -- I wouldn't think that it would affect anything like that; it should continue to do what it does with the same permissions regardless. It's almost surely not related to the main question, and may have little to do w/ nVidia. In any case, if I decide to pursue that one I'll raise a separate question for it. – Charles Boling Aug 18 '15 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.