1

I'm trying to install Bugzilla.

I have Phpmyadmin installed in my system so I can't follow the instructions on the Bugzilla site that tells me to remove the /var/www/html folder because I have Phpmyadmin in there.

Besides I have seen the instructions here on askubuntu, but I don't want to create other users on my machine and I want to install Bugzilla for my default user because I'm the only one who uses this machine.

Here are the steps I followed:

sudo su
apt-get install git nano
apt-get install apache2 mysql-server libappconfig-perl libdate-calc-perl libtemplate-perl libmime-perl build-essential libdatetime-timezone-perl libdatetime-perl libemail-sender-perl libemail-mime-perl libemail-mime-modifier-perl libdbi-perl libdbd-mysql-perl libcgi-pm-perl libmath-random-isaac-perl libmath-random-isaac-xs-perl apache2-mpm-prefork libapache2-mod-perl2 libapache2-mod-perl2-dev libchart-perl libxml-perl libxml-twig-perl perlmagick libgd-graph-perl libtemplate-plugin-gd-perl libsoap-lite-perl libhtml-scrubber-perl libjson-rpc-perl libdaemon-generic-perl libtheschwartz-perl libtest-taint-perl libauthen-radius-perl libfile-slurp-perl libencode-detect-perl libmodule-build-perl libnet-ldap-perl libauthen-sasl-perl libtemplate-perl-doc libfile-mimeinfo-perl libhtml-formattext-withlinks-perl libgd-dev lynx-cur python-sphinx
cd /var/www/html
git clone --branch release-5.0-stable https://git.mozilla.org/bugzilla/bugzilla bugzilla
cd bugzilla
gedit /etc/mysql/my.cnf`

Altered on Line 52: max_allowed_packet=100M

Added as new line 31, in the [mysqld] section: ft_min_word_len=2

mysql -u root -p -e "GRANT ALL PRIVILEGES ON bugs.* TO bugs@localhost IDENTIFIED BY '$my_pass'"
service mysql restart
gedit /etc/apache2/sites-available/bugzilla.conf`

Added:

ServerName localhost
<Directory /var/www/html>
  AddHandler cgi-script .cgi
  Options +ExecCGI
  DirectoryIndex index.cgi index.html
  AllowOverride Limit FileInfo Indexes Options
</Directory>

Then:

a2ensite bugzilla
a2enmod cgi headers expires
service apache2 restart
cd /var/www/html/bugzilla
./checksetup.pl

It gave me some errors so I run:

/usr/bin/perl install-module.pl –all
./checksetup.pl
gedit localconfig

Line 29: set $webservergroup to www-data

Line 67: set $db_pass to the password for the bugs user I have created in MySQL a few steps ago

./checksetup.pl (again)
./testserver.pl http://localhost/

And then I get this error:

strictures.pm extra testing active but couldn't load all modules. Missing were:

  indirect multidimensional bareword::filehandles

Extra testing is auto-enabled in checkouts only, so if you're the author
of a strictures-using module you need to run:

  cpan indirect multidimensional bareword::filehandles

but these modules are not required by your users.
TEST-OK Webserver is running under group id in $webservergroup.
TEST-FAILED Fetch of images/padlock.png failed
Your web server could not fetch http://localhost/images/padlock.png.
Check your web server configuration and try again.

So what did I do wrong?

As you can see I'd like to install Bugzilla /var/www/html/ folder where I have also Phpmyadmin so I will have: /var/www/html/bugzilla.

Thanks.

Edit: after running: cpan indirect multidimensional bareword::filehandles the problem is still:

TEST-OK Webserver is running under group id in $webservergroup.
TEST-FAILED Fetch of images/padlock.png failed
Your web server could not fetch http://localhost/images/padlock.png.
Check your web server configuration and try again.

Edit 2:

Ok, the only thing I found in apache2 logs is /var/log/other_vhosts_access.log:

localhost:80 127.0.0.1 - - [27/Jul/2015:10:29:06 +0200] "GET /images/padlock.png HTTP/1.1" 404 469 "-" "libwww-perl/6.05"

and /var/log/error.log:

[Mon Jul 27 10:14:38.112755 2015] [mpm_prefork:notice] [pid 7477] AH00163: Apache/2.4.7 (Ubuntu) PHP/5.5.9-1ubuntu4.11 mod_perl/2.0.8 Perl/v5.18.2 configured -- resuming normal operations
[Mon Jul 27 10:14:38.112794 2015] [core:notice] [pid 7477] AH00094: Command line: '/usr/sbin/apache2'
  • Did you run cpan indirect multidimensional bareword::filehandles ? – Rinzwind Jul 27 '15 at 8:43
  • Ok I did right now and the only problem that I still have is: TEST-OK Webserver is running under group id in $webservergroup. TEST-FAILED Fetch of images/padlock.png failed Your web server could not fetch http://localhost/images/padlock.png. Check your web server configuration and try again. – Frank Jul 27 '15 at 8:52
  • Check the apache2 log in /var/log/ for notices. (the problem is a config problem so not really something we can answer). Likely /var/log/apache2/error* is going to tell what. Oh could be a domain issue too. – Rinzwind Jul 27 '15 at 9:22
  • Ok, please see my edit. – Frank Jul 27 '15 at 9:35
0

For me (Linux Mint 17.2; Bugzilla 5.0.1, Apache 2.4.7) this helped (finally, after trying a lot of other things):

Changed AllowOverride Limit FileInfo Indexes Options to AllowOverride All

0

I am experiencing the same problem with Ubuntu 14.04, apache 2.4.7, bugzilla 5.0. Also wants to set as http://localhost/bugzilla.

The trick was to think... Yes, simply.

You executed:

./testserver.pl http://localhost

when in fact you should have used

./testserver.pl http://localhost/bugzilla

since it needs as input the location of itself (yeah, pretty dumb).

  • You are missing a "g". – Rinzwind Nov 19 '15 at 10:04
0

I am experiencing the same issue. The problem for me was related to the AllowOverride setting as well. This is in the file /etc/apache2/sites-enabled/000-default.conf and was set to the following:

<VirtualHost *:80>
  <"Directory /var/www/html/bugzilla>
    AddHandler cgi-script cgi
    DirectoryIndex index.cgi
    Options +Indexes +ExecDGI +FollowSymLinks +MultiViews
    AllowOverride Limit
    Order Allow,deny
    Allow from all
  <Directory>
<VirtualHost>

The line AllowOverride was changed to read:

AllowOverride None

The file /etc/apache2/sites-enabled/bugzilla.conf has the following Directory entry:

<Directory /var/www/html>
    AddHandler cgi-script .cgi
    Options +ExecCGI +FollowSymLinks
    DirecortryIndex index.cgi index.html
    AllowOverride All
</Directory>

That fixed the issue for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.