1

I have a dell vostro laptop with Ubuntu 14.04 dual boot with windows (wifi is working with windows). The wifi stopped working after resume/reboot. Wifi is unable to detect any networks.

PFB the related info

ifconfig
eth0      Link encap:Ethernet  HWaddr 5c:f9:dd:4b:2f:ca  
          inet addr:192.168.20.175  Bcast:192.168.20.255  Mask:255.255.255.0
          inet6 addr: fe80::5ef9:ddff:fe4b:2fca/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1962 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1962 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:204810 (204.8 KB)  TX bytes:204810 (204.8 KB)

sudo lshw -C network

  *-network               
       description: Network controller
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=bcma-pci-bridge latency=0
       resources: irq:16 memory:d0500000-d0507fff
  *-network
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 10
       serial: 5c:f9:dd:4b:2f:ca
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx duplex=full ip=192.168.20.175 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:45 memory:d0400000-d043ffff ioport:2000(size=128)

I tried sudo service network-manager restart but it did not help

Also, I managed to get wifi up again once by doing

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source && sudo apt-get install b43-fwcutter firmware-b43-installer

I have referred the following links :

http://ubuntuforums.org/showthread.php?t=2218043 Network connection error after suspend Ubuntu 14.04 Wireless networking not working after resume in Ubuntu 14.04 http://www.techytalk.info/ubuntu-fix-network-stopped-working-after-resume-from-sleep/

How to run a script? Can't connect to a specific WiFi network (Ubuntu 14.04) Why doesn't System Monitor show activity over ethernet connections? http://www.overclock.net/t/1518258/solved-wireless-suddenly-stopped-working-in-ubuntu-14-04/10

I have failed to find a solution. Please help I' new to Ubuntu.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.