1

UPDATE: The pendrive was for my parents. When I got a chance, I got it formatted from a Windows machine at my friend's house. I can't try any suggessions in the comments or answers, because I have left home for college. But I am interested to know why mkfs did not work. The pendrive was not recognize by Windows either after doing a mkfs.vfat. I will accept an answer which includes why mkfs did not work.


I have a working USB stick. I made a Ubuntu installation disk, probably using dd. Then after a while, when I reformatted it to use it with my car music system, it is not working. I get this:

USB device not recognised

I get this error when I try to format it from nautilus:

enter image description here

But it can be formatted by the below command but does not work with the player:

mkfs.vfat -n Musiq /dev/sdc1

Another pen drive, which was never formatted by me, works fine.

Here is the output of fdisk -l for the device:

Disk /dev/sdc: 8004 MB, 8004304896 bytes
212 heads, 46 sectors/track, 1603 cylinders, total 15633408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x74fdf679

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1            2048    15633407     7815680   83  Linux

Also this is the output of fdisk -l for the working pen drive.

The partition table is msdos. I strongly believe that I am not correctly formatting/partitioning the stick.

What could be wrong?

1
  • 2
    Have you tried the Disks utility or Gparted? Also, your working pen drive is formatted fat32, non-working shows Linux. You may want to format as fat32.
    – RCF
    Jul 27, 2015 at 5:33

3 Answers 3

3

try to format the pen drive as FAT32 using disk utility in Ubuntu. search for disk in dash.

0

The problem seems to be the partition type in the partition table. It is still Linux as it's shown by fdisk.

I could reproduce same thing here. I used gparted to create an Ext4 partition. Then mkfs.vfat to format it. It does format it but it leave its type as Linux in the table.

  • You may gnome-disks as mentioned by minion91, it could make only Fat32.
  • gparted support both Fat16/Fat32.
  • Manually:

    1. Run fdisk /dev/sdc1, t change type to e then w to rewrite the table.

    2. Then format it:

      mkfs.fat -F16 -n Musiq /dev/sdc1
      

Order Doesn't matter but replug it if partition size changed.

0

use parted command on linux if you don't have it just download it! so run the command below:

parted /dev/sdx
mklabel msdos
q

and then partition it by running the command:

fdisk /dev/sdx
n
then chose as you like for the configuration and then type:
t
then select the partition you just created for example we gonna chose 1
then type "0c" because we gonna change the type from linux to fat32 LBA
then type w

done your problem solved ezezezez edit:

so basicly the problem was when creating the partition with fdisk or even cfdisk change the type from "linux" to w95 fat32

done your problem solved again ezezezez

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.