1

I am pretty new to Linux and I am working to install Cuda, which requires the Nvidia Graphic Card to work. My laptop is Lenovo Y50-70 with a GTX960M card. My system is Ubuntu 14.04.

This is the result I got from the system:

jinchao@jinchao-laptop:~$ sudo lshw -C display
[sudo] password for jinchao: 
  *-display               
       description: 3D controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:51 memory:d0000000-d0ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128) memory:b2000000-b207ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:47 memory:d1000000-d13fffff memory:c0000000-cfffffff ioport:5000(size=64)

I have tried several solutions described in many posts, like: Ubuntu and ASUS G750JM, GTX860M / Nvidia problems, How do I get Ubuntu to recognize my nvidia graphics card?, Why does Ubuntu 14.04 not recognize NVIDIA GeForce 310M hardware?, and many else. Unfortunately none of them works for me. I even try to install ubuntu 15.04, but the same problem still exists.

It seems my problem is a little different from most the post. In most post, at least when they run sudo lshw -C display, the system can detect the correct model of the graphic card, while in my case, it only detects product: NVIDIA Corporation.

Can anyone help me? Really apreciated !

0

You need to install a new driver for this brand new model. Run in terminal

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-352 nvidia-prime
sudo add-apt-repository -r ppa:xorg-edgers/ppa

and reboot.

  • Hi Pilot6, thanks for your comment. But after I remove the old driver and re-install the new nvidia-352 driver and nvidia-prime, nothing changes. The 'sudo lshw -C display' command still output the exact same result. – abrocod Jul 26 '15 at 0:30
  • 1
    And after install the new driver, after reboot, my ubuntu becomes black screen at login stage (I can hear the login sound but see black screen). So I have to remove the driver again. – abrocod Jul 26 '15 at 3:56
0

I know this is an old post, but I just installed Ubuntu 14.04.4 on a Lenovo Y700 with an NVIDIA GEForce 960M GTX graphics card and was having the same issues. I figured out that if I changed the Graphics from 'Switchable' to 'Internal' in the BIOS, then the problem went away. Upon further inspection the 'internal card' was an Intel. Not exactly an ideal solution if you want the NVIDIA card for gaming, but it worked for me.

  • There was no need to disable UEFI. But if you had Windows installed without UEFI it could make sense. – Pilot6 Feb 26 '16 at 21:39
  • This sounds like you have an used nvidia card sitting in your case. I'll take it off your hands... – notbad.jpeg Oct 18 '16 at 14:12
  • Yes, but sorry, this is a work computer, so I don't feel comfortable taking it out. – PaulFrater Oct 20 '16 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.