1

I have been having this strange problem for a month or so. I have installed Ubuntu 14.04 alongside Win8.1 on my Lenovo z510. It worked fine for about 5 months, but almost a month ago, I started getting error at the grub menu in grub grub rescue>filesystem is unknown. Sometimes I also used to get a error:trying to read/write outside hd0 or similar.

A workaround was a few restarts, or a manual set of root and insmod normal from the rescue prompt was to be done. I got fed-up with this and overwrote grub with the windows bootloader. This time, it worked(although it boots directly into Windows). I never got any error while booting. Yesterday I reinstalled ubuntu hoping it will work again but it is just like before. Anyone has any ideas/solutions on how to get ubuntu working?

  • Is your system using UEFI BIOS? You might want to make sure SafeBoot is disabled if you're dealing with one. – Ian Jul 25 '15 at 6:22
  • It is but both the OS are installed as Legacy. And SecureBoot is disabled too – blumonkey Jul 26 '15 at 7:37
0

Try Boot-Repair

Live Boot the ubuntu and install it or use ubuntu secure remix which have with boot-repair in it. Connect to internet white working with Boot-repair.

https://help.ubuntu.com/community/Boot-Repair

  • I have already tried that. It gives the same result. – blumonkey Jul 26 '15 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.