2

I could not get my Subwoofer on Lenovo Y50 to work. Googled around and did not find any solutions. Let me know if anybody has any clue. Thanks!

2
  • How is the Subwoofer attached to the computer? You are using a computer, right? What leads you to believe it is not working?
    – waltinator
    Jul 25, 2015 at 1:00
  • @waltinator The y50 has a built in subwoofer
    – this.foo
    Jul 30, 2015 at 10:53

4 Answers 4

1

This is what worked for me:

first, install and run HDA Analyzer:
wget -O run.py http://www.alsa-project.org/hda-analyzer.py
sudo python run.py (root is required)

second, using the gui do this:
•PIN 0x17 -> Widget Control -> Check OUT and Uncheck Mute:
enter image description here

•PIN 0x1a -> VREF -> Set it to 100:
enter image description here

And third, test it by listening to some music.
If it still isn't working, you can follow this thread, maybe someone will find an answer:
(https://superuser.com/questions/945110/how-do-i-make-my-lenovo-y50s-subwoofer-work-on-linux)

HDA Analyzer can be found here: http://www.alsa-project.org/main/index.php/HDA_Analyzer

4
  • Thank You for the useful info. According to similar problems on other laptops [ex. reddit.com/r/linux/comments/17sov5/… i tried use hda-jack-retask to mapping this pins as a subwoofer but it's seems to be more complicated there is two pins as one subwoofer... I can't figure out. Not luck for me but maybe You will try. I think Yoou can have some better knowlege / ideas in this case. Cheers! Sep 8, 2015 at 20:19
  • Note that run.sh should be executed with python2.
    – miyalys
    Sep 19, 2015 at 14:40
  • @ShupingRuan That's Great. Are you running Ubuntu or something else? Also please check the answer as the right one if it worked and consider upvoting it if it was Informative. Thank you.
    – this.foo
    Sep 24, 2015 at 15:40
  • Ohhh, thanks a lot. Since I installed Ubuntu I forgot that this laptop actually has a nice sound system.
    – Anti
    Nov 11, 2017 at 20:50
1

I got my Y50-70 sub-woofer working by doing this:

in /etc/pulse/default.pa add this line at the end:

load-module module-combine channels=3 channel_map=front-left,front-right,lfe

then in /etc/pulse/daemon.conf change ;enable-lfe-remixing = no to enable-lfe-remixing = yes note that you have to remove the ;

then reboot.

Tested and validated on Kubuntu 15.04.

4
  • the daemon.conf file seams to be empty
    – this.foo
    Jul 30, 2015 at 10:59
  • Same here. No deamon.conf file. I am using Ubuntu 14.04.2 LTS. Should I update to Ubuntu 15.04?
    – Ping
    Jul 31, 2015 at 17:17
  • if you want to, but it maybe don't be the solution, you can try. If you do it, don't forget do a back backup... I don't know why the daemon.conf is empty , ¿did you use root privileges when you edit the the daemon.conf ?. Sorry i can't help you more. Aug 13, 2015 at 1:49
  • Hmm... this seems not work on Ubuntu 14.04 did anybody test this on Ubuntu 15.04 maybe it will be time for upgrade system ;) Sep 8, 2015 at 20:32
1

In the referenced Super User question and its recent followup, we managed to get it to work, and you can do it all by:

First installing alsa-tools (which contains hda-verb)
and then executing this shell script as root:

#! /usr/bin/env sh

# Run this script as root!

dev="/dev/snd/hwC1D0"

hda-verb $dev 0x17 SET_POWER 0x0
hda-verb $dev 0x1a SET_POWER 0x0
hda-verb $dev 0x03 0x300 0xa055
hda-verb $dev 0x03 0x300 0x9055
hda-verb $dev 0x17 0x300 0xb000
hda-verb $dev 0x17 0x707 0x40
hda-verb $dev 0x1a 0x707 0x25

Side note: Actually it can also be done without hda-verb, using python alone (which hda analyzer can export), but the code would be considerably more messy.

If you want to do it more manually for some reason, here's how:

Install alsa-tools via apt-get or similar.

Get HDA Analyzer like this:
wget -O run.py http://www.alsa-project.org/hda-analyzer.py

Side note: hda-analyzer will only run correctly on your machine if python is a symlink to python2, which it normally is, but there are exceptions. (Arch linux, at least.)

Run HDA Analyzer:
python run.py

Inside HDA Analyzer, look under card 1.

Changes to node 0x17:
Untick Val[0]: Mute
Tick Out under Widget Control.

Changes to node 0x1a
Set VREF under Widget control to 100 instead of hiz.

Quit hda_analyzer.

Run these two hda-verb commands, again as root:

hda-verb /dev/snd/hwC1D0 0x17 SET_POWER 0x0
hda-verb /dev/snd/hwC1D0 0x1a SET_POWER 0x0

Start hda_analyzer again.

Increase the output volume of node 0x3 (AUD_OUT) on card 1:
In HDA Analyzer under Output amplifier push the Val[0] and Val[1] sliders towards the right. They may need to be almost all the way over to the right before you can hear the difference.

Here's a low frequency audio file you can use for testing.

You can test it by plugging something into the headphone plug, as the subwoofer is unaffected by that being plugged in unlike the normal speakers, at least after the above is changed. That problem is unfortunately not solved by the shell script either.

1
  • after shell scripts executed the output volume set to 100% this is very annoyng. any ways to fix this?
    – Alex0007
    Apr 3, 2016 at 21:30
0

Try setting lfe-crossover-freq = 0 in /etc/pulse/daemon.conf

1
  • Never mind, I can see you fixed your problem. I fixed my problem by doing this however.
    – Kristoffer
    Jul 28, 2016 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.