I've tried searching for the EPSON MX14 driver on Google but nothing turns up. I get similar model numbers, but nothing exact. These drivers didn't work.

I click on 'System Settings' - 'Printing' - 'Add' - 'Windows printer via SMB'- then browse the LAN and successfully find the correct printer (EPSON AL-MX14)

I click OK, Ubuntu throws up a list of brands, and the printer isn't found among the options. I instead choose to install a generic driver. I am prompted to print a test page, which yields the message "CUPS server error. There was an error during the CUPS operation: 'client-error-document-format-not-supported.'"

Has anyone overcome this problem before?

  • I have the same problem and have tried the ppd file from the Mac OS package. It doesn't work... There are complications that CUPS asked me to install filter files (that can be found in the package). I then copied the filters to /usr/lib/cups but in vain. Actually, there were also some .dylib files that I ain't sure where to put (but I copied it to /usr/lib/cups for a try anyway). I guess it does require a Linux specific driver. – user22514 Apr 9 '12 at 20:59

May try this reference :

hopefully help you..


I was looking for information about this multifunction printer and if it would work with Linux, and found your question.

The user manual reports that for Mac OS X 10.4.11 the printer should work starting with CUPS 1.2.12. I don't know if this also means that the printer is also supported with CUPS for Linux, but I guess so.

I didn't found anything so far about the scanner. I hope the sane-epson2 backend will support the scanner one day.

It's been a while since you asked your question. Did you make any progress?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.