4

Here is an image of the network I'm setting up:

network-map

This network sort of works when "Computer" is running OS X; I can access "Network camera" (an Axis M1011) at its default address 192.168.0.90 and set a new IP address (e.g. 10.0.0.12) through the camera's browser interface only when Wi-Fi is turned off. I can also view the camera's video feed, etc. When Wi-Fi is turned on, I cannot reach "Network camera" at the address I set. (This at least confirms that everything on the switch is working, and that I can configure "Network camera" if need be.)

axis-camera-settings

Relevant documentation:

I'm setting up this system for a robotics application, and I need "Computer" to run Ubuntu 14.04. However, when I plug "Switch" into "Computer" Ubuntu tries to connect to "Wired connection 2" (or "Wired connection 1" if I plug the Ethernet cable into the other motherboard Ethernet port), eventually disconnecting.

Here is the output of ifconfig after setting everything up as pictured:

ifconfig

An here is the output of route and route -n:

route

I've tried the following link:

However, it seems that I have to solve the problem of getting Ubuntu to actually connect through "Switch" first, since it isn't even showing up in route and Ubuntu disconnects from "Wired connection 2" after a short time (and periodically tries to reconnect).

At the very least, I would like to reproduce with Ubuntu the situation on OS X, where I can access "Network camera" if I disconnect from WiFi. Ideally, I would like to be able to access the internet wirelessly and the network cameras on the switch without having to disable one of the connections.

4

I arrived at a solution after watching the following video: https://www.youtube.com/watch?v=yqJ9PXhqOAQ

  • Launch Network Connections, e.g. by clicking on the network icon at the upper right and choosing "Edit Connections..."
  • Select the "Wired connection #" corresponding to the Ethernet port that will be connected to the switch. Choose "Edit..."
  • Under the IPv4 Settings tab, change the Method drop-down from "Automatic (DHCP)" to "Disabled"
  • Choose "Save..." A duplicate connection may appear in the list; choose "Close" and re-open Network Connections, and the duplicate will be gone (the duplicate item is a bug)
  • Choose "Add", select "Ethernet", and choose "Create..."
  • Type any name, e.g. "Cameras switch"
  • Under the IPv4 Settings tab, change the Method drop-down to "Manual"
  • Choose "Add" next to Addresses, and set Address to some value (e.g. 10.0.0.9) and Netmask to 255.255.255.0; leave Gateway blank. The address is for the Ubuntu computer, so it should be different from the camera addresses.
  • Fill the DNS servers field with some address, e.g. 10.0.0.10
  • Choose "Save..." and "Close"

Plug the switch into the Ethernet port. The "Cameras switch" connection should connect automatically. Now the network camera browser interface can be accessed at its IP address. Using ping followed by the camera's IP address in Terminal should also be successful. Additionally, connecting to the wireless network allows access to the internet (e.g. www.wikipedia.org) in addition to the network camera at its IP address.

(Everything works acceptably now, but if anyone could explain in the comments the Default router field in the Axis camera TCP/IP browser settings (see the second image in the question text) or the DNS servers field under the IPv4 Settings tab when creating a manual Ethernet connection I'd be grateful. I'm not sure what role those addresses play.)

Note that everything can be undone relatively easily by deleting the "Cameras switch" connection and setting "Wired connection #" from "Disabled" back to "Automatic (DHCP)"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.