2

I'm reading a line in some instructions and one of the steps is written as:

sudo apt-get -f install # Install dependencies and finish configuring the packages(s)

so i'm wondering is the "#" what i'm supposed to enter or should i be replacing with a list of packages that needed to be installed from the previous command which was this:

james@james-Galago:~/Desktop/Installers/Citrix$ sudo dpkg -i icaclient_13.1.0.285639_amd64.deb 
Selecting previously unselected package icaclient.
(Reading database ... 580367 files and directories currently installed.)
Preparing to unpack icaclient_13.1.0.285639_amd64.deb ...
Unpacking icaclient (13.1.0.285639) ...
dpkg: dependency problems prevent configuration of icaclient:
 icaclient depends on libgtk2.0-0:i386 (>= 2.12.0); however:
 icaclient depends on libcanberra-gtk-module:i386; however:

dpkg: error processing package icaclient (--install):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Errors were encountered while processing:
 icaclient

I'm not sure if i need to do anything with these triggers listed above such as mime-support... I'm trying to configure my 14.04 to vpn using CAG:

https://help.ubuntu.com/community/CitrixICAClientHowTo

When I run:

sudo apt-get -f install

I get:

james@james-Galago:~/Desktop/Installers/Citrix$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libatk1.0-0:i386 libcanberra0:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386
  libgraphite2-3:i386 libjasper1:i386 libpixman-1-0:i386 libspeex1:i386
  libtdb1:i386 libthai0:i386 libvorbisfile3:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxerces-c3.1 libxmu6:i386
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  icaclient
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 37.4 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 580841 files and directories currently installed.)
Removing icaclient (13.1.0.285639) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...

1 Answer 1

10

Simply run

sudo apt-get -f install

without anything additionally things. # is only the opener for a comment

To install packages, use

sudo apt-get install package_name

Replace package_name with the name of the package to install.


In your case

sudo apt-get install -f

and if that not works

sudo apt-get install libcanberra-gtk-module:i386
sudo apt-get install libgtk2.0-0:i386

An alternative to install the deb file is

software-center icaclient_13.1.0.285639_amd64.deb

From man apt-get

   -f, --fix-broken
        Fix; attempt to correct a system with broken dependencies in
        place. This option, when used with install/remove, can omit any
        packages to permit APT to deduce a likely solution. If packages 
        are specified, these have to completely correct the problem. The 
        option is sometimes necessary when running APT for the first 
        time; APT itself does not allow broken package dependencies to 
        exist on a system. It is possible that a system's dependency 
        structure can be so corrupt as to require manual intervention 
        (which usually means using dpkg --remove to eliminate some of the 
        offending packages). Use of this option together with -m may 
        produce an error in some situations. Configuration Item: 
        APT::Get::Fix-Broken.
8
  • ah so the "#" was intended to be a comment...? i entered it and got the same result. Did not seem to install but think you answered the question. :)
    – simgineer
    Jul 24, 2015 at 17:29
  • Of course, you helped me last time so very happy to give you credit. Based on the output from my running that install command should the next command i try be: sudo apt-get install libgtk2.0-0:i386 and then sudo apt-get install libcanberra-gtk-module:i386
    – simgineer
    Jul 24, 2015 at 17:53
  • apt-get install -f sounds good as next command. :)
    – A.B.
    Jul 24, 2015 at 17:55
  • When I do that (with -f) it just removes the icaclient. Posted output up top.
    – simgineer
    Jul 24, 2015 at 18:04
  • No problem, install the dependencies first and after that the deb package.
    – A.B.
    Jul 24, 2015 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.