4

Earlier I used Ubuntu 12.04 where my Vodafone 3G Dongle (HUWAEI modem) used to connect seamlessly via network manager Mobile Broadband. Now I have upgraded my system and using Ubuntu 14.04, but whenever I try to connect to Vodafone 3G using the network manager, it searches for some time and fails to connect.

When I plug in the device, Ubuntu network manager detects it and displays the name, on clicking it first it searches to connect and displays the following message "Mobile Broadband Network : You are registered to home network", which is expected. But then, it fails to connect and disconnects the connection.

Now installation of the software given in the modem is a nightmare as everytime it fails for some reason, thats why in my 12.04 I used to connect via the Network Manager. I have checked the APN settings which is standard for Vodafone.

Device : Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard Vodafone 3g K4203I

Thanks!

Problem

3

Seems like there is some problem with the driver of your modem. I have tried a script called Sakis3G to get some unsupported dongles working in Ubuntu. This should work just fine for your dongle too. Download it from here: http://dev.oikyolinux.com/files/sakis3g.7z Please see the read me file included in the 7z archive if having problem executing the script.

  • 1
    yes this script worked perfectly! Thanks a lot! :) – Koustuv Sinha Jul 24 '15 at 7:03
  • What did you use for apn username and password ? – Saurabh7 Mar 26 '16 at 14:21
  • Those fields should be blank for most cases. – Pavak Paul Mar 26 '16 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.