0

When I was trying to mount my Windows hard disk I got this error:

Error mounting /dev/sda1 at /media/ubuntu/System: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=999,gid=999,dmask=0077,fmask=0177" "/dev/sda1" "/media/ubuntu/System"' exited with non-zero exit status 13: Corrupted file $UpCase  
Failed to mount '/dev/sda1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.
(udisks-error-quark, 0)

What should I do?

  • Did you shut down Windows politely? ASFAIK, it keeps some filesystem info in RAM, and sets a flag on the disk saying so. If you just hit the big red switch (instead of letting Windows shut itself down), the filesystem on disk says "I am inconsistent, see the info in (Windows, gone) RAM. FAIL. – waltinator Jul 24 '15 at 2:43
  • The message tells you what to do "run chkdsk /f on Windows then reboot into Windows twice." – Panther Jul 24 '15 at 3:31
  • 3
    Possible duplicate of Unable to mount NTFS external hard drive – Zanna Mar 7 '17 at 21:04
2

Run:

 sudo ntfsfix /dev/sd(the location of the Windows filesystem)

For example if the partition is /dev/sdb1 that's what you would enter in the command. You can find the partition with lsblk or sudo fdisk -l

0

You should read (carefully) the error message:

NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.  

It shows a couple of things you could try:

run chkdsk /f on Windows then reboot into Windows twice  

If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.