1

I run a dedicated landscape server for personal use, but I can't run scripts?

I am getting this messagevery time :

System error

An unexpected error has occurred. This event has been logged.

We apologize for the inconvenience. Please contact Canonical Support for >further assistance.

OOPS ID: 3490DFA8

Jul 23 23:45:54 appserver-1 ERR https://Landscape/account/standalone/computers/update#012Traceback (most recent call last):#012 File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 132, in publish#012 result = publication.callObject(request, obj)#012 File "/usr/lib/python2.7/dist-packages/zope/app/publication/zopepublication.py", line 205, in callObject#012 return mapply(ob, request.getPositionalArguments(), request)#012 File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 107, in mapply#012 return debug_call(obj, args)#012 File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 113, in debug_call#012 return obj(*args)#012 File "/opt/canonical/landscape/canonical/landscape/ui/selection/selection.py", line 110, in update#012 self.request.response.redirect(next_url)#012 File "/usr/lib/python2.7/dist-packages/zope/publisher/browser.py", line 759, in redirect#012 return super(BrowserResponse, self).redirect(location, status, trusted)#012 File "/usr/lib/python2.7/dist-packages/zope/publisher/http.py", line 886, in redirect#012 % target_host)#012ValueError: Untrusted redirect to host 'landscape:443' not allowed. Jul 23 23:45:54 appserver-1 WARNING Dumping OOPS 3490DFA10.

Is there anyone with the knowlgede to resolve this ? i am able to create scripts but as soon as i choose wich server to execute it on i am getting this message

2
  • You seem to have hit a bug. Please attach the appserver logs here, they will contain the reason for the System Error. It's /var/log/landscape-server/appserver.log IIRC. – Andreas Hasenack Jul 23 '15 at 21:41
  • i have updated the Question. IIRC? – Daniel Guldberg Aaes Jul 23 '15 at 21:47
4

You have a mismatch between the landscape root-url in the "LDS Settings" page and what you are actually using in your browser to access it.

Either change the way you access landscape in your browser (have it match what is in root-url currently), or change the root-url value. If the latter, you have to restart the landscape services after the change with "sudo lsctl restart" on the landscape machine(s).

2
  • i found it under /etc/landscape/service.conf and changed it to landscape:9100, i have also added 10.0.2.47 to /etc/hosts/ and it worked for like 2 min and then the error returned? – Daniel Guldberg Aaes Jul 27 '15 at 14:32
  • This is odd, i have a client setup and lets call it Ubuntu1. If i enter - Computers -> Ubuntu1 in the browser then i can use all the functions from the tab but if i choose Computer -> and use the checkmark whre i can select more than one client and then want to go to script then the error will appear. I have tried to do a fresh install without any luck. – Daniel Guldberg Aaes Jul 27 '15 at 14:56
1

Check the hostname throughout /etc/apache2/site-enables/your-lusu-server.conf

In mine part of the host was Capitalised.

it was like that in three places.

ServerName
ServerAdmin
RewriteRule
ServerAdmin
RewriteRule
RewriteRule

After changing it to all lower case, everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.