0

I have tried all solutions found here or on ubuntuforums.com, but no luck whatsoever.

It all started very randomly: I had my mother's nokia lumia connect via usb to my lenovo x230t, I disconnected it (without safely removing it first - ouch) and, when I unplugged the cable, I got the network disconnection alert on the top right corner of the screen and the wifi got hardware blocked.

My rfkill list is

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
1: tpacpi_wwan_sw: Wireless WAN
    Soft blocked: no
    Hard blocked: yes
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

After this moment it the "Enable wifi" option has always been greyed out. I've tried :

  • the FN+key button, but no message whatsoever (actually looks like that command is not recognised)

  • sudo rfkill unblock 1 and 2, but no effect whatsoever

  • sudo rfkill unblock all, but nothing

  • blocking first, and this changes the no to yes, but then redoing sudo rfkill unblock 1changes only the Soft blocked, leaving the Hard blocked to no

  • echo blacklist acer-wmi | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf and nothing even here

  • tried in the BIOS, but in my version there's no "Wireless Radio LAN" option

Another piece of information: every time I open System settings -> Network, the Airplane mode is on This has never happened before, so the cause is surely linked to the unplugging the smartphone. Maybe it hit on a system bug. Now the question is: how do I fix it?

I beg some expert for help, as this is the laptop I use for work and not being able to connect wirelessly is creating quite some problems. Thank you

  • Can you provide dmesg output? – Arch user Jul 24 '15 at 8:35
  • Does your PC has an hardware switch(eg. Fn+wireless, trigger,...). If so, try to toggle it (there won't be any output) and check rfkill status again – Arch user Jul 24 '15 at 8:39
  • Yes, there's the Fn key but pressing it with the wireless button has no effect whatsoever, not even a symbol or communication on the screen. nothing, dead. I'm posting the output of dmesg on an answer as it's too long for a comment – andrea Jul 24 '15 at 11:39
  • Use pastebin to post dmesg output – Arch user Jul 24 '15 at 11:46
  • thanks, great idea! here's the URL (hope this is the right way) pastebin.com/MuHKqZ0F – andrea Jul 24 '15 at 11:49
1

if you have the realtek NIC then you should try this tape trick to mask a pin only after the problem still persists after trying the other solutions such as unblock command. In my laptop the same problem had occurred and I myself applied the trick and since then my WiFi works like charm.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.