0

I'm following along with the book How Linux Works, and am trying to get the Python SimpleHTTPServer to work on its default port. I can access my home folder on the local host, but any other computer trying to access :8000 times out.

I have port forwarding enabled in my router for port 8000, and yet nmap returns output

PORT STATE SERVICE REASON 8000/tcp filtered http-alt no-response

nmap output to my other computer's IP is as follows

PORT STATE SERVICE REASON 8000/tcp closed http-alt conn-refused

Other than this, I have not set up any rules in IPTables.

Furthermore, I've tried this on both my home and work networks, completely disabling my home router's firewall with no success on either network.

1
  • Add how you're creating the server, and nmap output. – xyz Jul 23 '15 at 17:27
0

Try this: iptables -F and try to connect again to the port 8000, even if you have not changed your firewall, maybe your distro comes with a pre configured firewall. The previous command makes a flush (-F) to the firewall's tables, all chains are cleaned, basically deactivate the firewall.

If you are working with ufw (Uncomplicated Firewall), use the following command: sudo ufw disable for do the same (deactivate the firewall) and try to connect to the port 8000.

1
  • Thanks, disabling ufw did it. I'll have to play with it some so I can access port 8000 without leaving myself completely vulnerable. – burningserenity Jul 24 '15 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.