2

I've clean install ubuntu 15.04 and updated all required packages for installing:-

LINUX X64 (AMD64/EM64T) DISPLAY DRIVER

Version: 346.87

Release Date: 2015.7.21

Operating System: Linux 64-bit

And enable multi architecture support for installing nvidia 32-bit library

sudo -i
cd /etc/apt/sources.list.d
echo "deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list
apt-get update
apt-get install ia32-libs

After which i've installed packages

  1. sudo apt-get install linux-source linux-headers-$(uname -r)
  2. sudo apt-get install build-essential dkms
  3. To delete all the nouveau driver

    sudo apt-get --purge remove xserver-xorg-video-nouveau

  4. Blacklisted nouveau driver in modprobe.d as

    sudo gedit /etc/modprobe.d/nvidia-346_updates.conf

    And inserted :-

    #Necessary to install nvidia drivers
    blacklist nouveau
    blacklist lbm-nouveau
    blacklist nvidia-173
    blacklist nvidia-96
    blacklist nvidia-current
    blacklist nvidia-173-updates
    blacklist nvidia-96-updates
    alias nvidia nvidia_current_updates
    alias nouveau off
    alias lbm-nouveau off
    options nouveau modeset=0
    
  5. sudo update-initramfs -u

  6. And rebooted go in grub menu and set "nomodeset"
  7. login in text mode and stoped lightdm service by

    sudo service lightdm stop

  8. sudo chmod +x NVIDIA-Linux-x86_64-346.82.run
  9. sudo ./NVIDIA-Linux-x86_64-346.82.run --no-opengl-files

The installer exit by giving error that unable to load kernel module Can anyone please help me describing why this error is occurring and why i am unable to install it and also how to set-up external monitor where the HDMI port is connected to NVIDIA card The external monitor connected using HDMI to DVI cable. As i also want to get proper instruction manual for setting this type of setup. Thnxxxx in advance.

  • 1
    Where did you get the idea to add raring repositories to 15.04? that sounds like a recipe for trouble: 32-bit support is now provided by the mutliarch mechanism rather than the old ia32-libs package. – steeldriver Jul 23 '15 at 11:55
  • As i also want to install nvidia 32-bit libraries which required this therefor i installed ia32-libs – Gaurav Jul 23 '15 at 12:43
  • And i also tried without enabling that multiarch but still no luck – Gaurav Jul 23 '15 at 12:51
  • If you still facing this problem, could you edit question and add the complete output of sudo ./NVIDIA-Linux-x86_64-346.82.run --no-opengl-files – user.dz Nov 17 '16 at 11:45
-1

The NVidia driver version 346 is available as an Ubuntu package.

apt-get install nvidia-346 

should get you going.

| improve this answer | |
  • I know as i can use this as Propitiatory Drivers but when i am installing same driver through nvidia site why i am getting this error on ubuntu 15.04 – Gaurav Jul 23 '15 at 12:42
  • The ubuntu package contains a lot of modifications to make the kernel module cooperate with the DKMS infrastructure. If you are interested, look at the source package and compare what you did, to see the differences – arved Jul 23 '15 at 13:13
  • Could you provide me the link of source package – Gaurav Jul 23 '15 at 13:15
  • packages.ubuntu.com/vivid/nvidia-346 – arved Jul 23 '15 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.