0

I'm having an incredible amount of trouble installing Ubuntu on an Asus K501LX.

I'm booting from a USB drive, created by usb-creator-gtk. I've attempted Ubuntu 14.04 and 15.04, as well as Kubuntu 15.04 (all 64-bit).

When I select "Try Ubuntu", 15.x hangs on the Ubuntu splash screen, while 14.x seems to work. However, when I select "Install Ubuntu", both 14.x and 15.x versions just throw a bunch of SCHED_ERR messages and crash. Kubuntu goes past the load screen, but then goes to a black screen and hangs.

I've been through all of the troubleshooting documentation with no luck. My md5 hash is fine, running "Check disk for defects" yields an all-clear, fast bootup and secure bootup have been disabled. Does anyone have any ideas what could be causing this problem or how it could be remedied?

1
  • Did you install Bumblebee or Prime and which nvidia driver? Then did you manage to have the touchpad working with two fingers? how? Finally, what about the keyboard? the backlight and the "function key'? I had quiet a lot of difficulties with Ubuntu 15.04. I'm going to try with Ubuntu 14.04.
    – Yogo Iran
    Sep 26 '15 at 20:54
1

I had the same issue with my k501lx. I finally got ubuntu working by enabling CSM in BIOS (you will have to disable SecureBoot first).

2
  • Though this may be correct, it would be good to include the steps to perform this task
    – Mark Kirby
    Aug 4 '15 at 6:57
  • This isn't really needed, as Ubuntu supports UEFI. I suppose the problem is with the USB drive created by usb-creator-gtk.
    – kos
    Oct 9 '15 at 15:04
0

You can leave disabled CSM and instead edit grub configuration file at boot.

The problem is about nouveau open source driver for Nvidia graphic card.

So, when you boot your usb and get grub screen press e when selecting try ubuntu and add after quiet splash the following string:

nouveau.modeset=0

This will disable nouveau driver. The edited line should now seems to this:

linux    /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubuquity quite splash nouveau.modeset=0 --

If this works, once you have installed Ubuntu, to keep things working, you have to add nouveau.modeset=0 to grub configuration file or blacklist nouveau driver.

A - Grub configuration file (my solution)

Change grub configuration file opening it as administrator:

sudo nano /etc/default/grub

add nouveau.modeset=0 to the following line as showed:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

then save with ctrl+o and exit with ctrl-x. Now you have to update grub with the following command:

sudo update-grub

B - Blacklist nouveau module

You can find a good example here to blacklist a kernel module (in this case nouveau)

I hope that one of 2 solution works also for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.