0

I tried to login to Ubuntu 12.04 but each time I get back to the login screen, I've tried (Ctrl+Alt+F1) to try console mode but after giving my login/password the message incorrect login appears, so I tried recovery mode the FS is mount with read only i changed it to rw :

mount -o remount,rw /

return to the login screen and nothing happened. I changed /etc/fstab options from errors=remount-ro to rw, reboot the system and the problem persist Any help please, I need an explanation to this issue if possible. Many thanks

  • I recommend booting a live system (from CD/DVD/USB) and investigating from there. Try to mount your root partition and right afterwards look at the last handful of lines of the output of sudo dmesg. It should contain info about the mount procedure. Is there anything interesting? If you're unsure, include the relevant section in your question (with the help of the edit function). – David Foerster Aug 3 '15 at 9:24
0

When file system or hard disk have errors it will show as read only file system. Reboot the system and go to recovery mode. Get the root command prompt and run fsck on all partitions. After successful file system check reboot the system and try login.

Hope this helps.

  • unfortunately this did not work. – Da ly Jul 23 '15 at 11:59
  • Did the file system check run successfully? – ATR Jul 23 '15 at 13:34
  • yes it terminated with success – Da ly Jul 23 '15 at 15:35
0

on grub pick recovery options. Log as root, and do fsck /. Then reboot. If you hasn't root account, first on grub with option "c" use passwd command to set root password

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.