0

I recently got an alert from my HIDS (Host Intrusion Detection System) about this.

I then checked syslog for the entries around that time, here is an extract.

After reading the some more on this, I now know that this is a bug in Tracker, and there is a bug report here on it (this bug has been fixed in the Debian version), however as nothing is being done about that bug report at the moment, I need some sort of workaround. So I was wondering if there is any way to stop Tracker indexing file contents and so that it only indexes file names (although as disabling Tracker causes issues with other applications which depend on it, disabling it fully is not really an option)? As currently it is indexing file contents and then logging to syslog about it, so loads of stuff including my emails and other private data is going in there.


OS Information:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid

Package Information:

tracker:
  Installed: 1.2.5-0ubuntu2
  Candidate: 1.2.5-0ubuntu2
  Version table:
 *** 1.2.5-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
        100 /var/lib/dpkg/status
0

These messages are related to Tracker (https://wiki.gnome.org/Projects/Tracker/). In the log file it seems to report about everything that it has indexed so your idea about email might be true. According to this error report the problem is solved in Debian. And a bug report has been filed about it in Ubuntu.

| improve this answer | |
  • Submitting a bugreport is never wrong. The worst thing that can happen if you decide to file a bug report is that it gets dismissed. Since the problem is apparently solved in Debian I suppose it will eventually be solved in Ubuntu too because Ubuntu is based upon Debian. – wie5Ooma Jul 23 '15 at 21:16
  • Do you know of any way to disable Tracker's feature which indexes file contents? As that would suffice would the time being. – user364819 Jul 24 '15 at 14:43
  • Please stop changing your question which was already answered with an accepted answer. Instead ask a new question. Since your rep is quite high you should know that already. Anyway, it seems you can remove tracker using synaptic. Be careful because there might be unwanted side-effects. – wie5Ooma Jul 24 '15 at 19:32
  • I don't want to remove it, just disable the feature of indexing file contents somehow. I only changed my question because it would be pointless to create a new one. Anyway, my question wasn't exactly properly answered, so with the new information provided, I edited my question as I finally knew what I was actually asking about. – user364819 Jul 24 '15 at 19:34
  • Disabling tracker globally: Edit /etc/xdg/autostart/trackerd.desktop file with root privileges (sudo) and add "Hidden=true" to the end of the file. Do the same for /etc/xdg/autostart/tracker-applet.desktop if you want. I did not test this myself but found it somewhere. – wie5Ooma Jul 24 '15 at 23:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy