23

I updated an Ubuntu 12.04 machine to 14.04.

The 12.04 install just had qt4, and had

/usr/lib/x86_64-linux-gnu/qt4/bin/designer

The 14.04 install has qt5, but I cannot get a

/usr/lib/x86_64-linux-gnu/qt5/bin/designer executable installed.

I have libqt5designer5 and libqt5designercomponents5 installed, and I get the libs but not the application.

I also have a bunch of qtquick packages installed.

How should I proceed?

38
sudo apt-get install qttools5-dev-tools

solved the problem.

The designer is included in the package "qttools5-dev-tools".

[$ nbviewer]$ apt-file search /usr/lib/x86_64-linux-gnu/qt5/bin/designer 
qttools5-dev-tools: /usr/lib/x86_64-linux-gnu/qt5/bin/designer
3
  • 2
    That worked for me too. It should probably be marked as the answer. – Alexis Wilke May 18 '16 at 7:11
  • Worked also on 16.04. +1 for marking this as the accepted answer. – Peter Apr 6 '18 at 9:04
  • In 16.04 /usr/bin/designer is just a symlink to qtchooser. It decides by the link name which tool to start. If you have multiple Qt versions installed you can give it one of the versions given by qtchooser -l. E.g. designer -qt5 will open the Qt5 version of designer. – Peter Apr 6 '18 at 9:14
7

In the library packed are no binaries for the designer application.

Install the designer with

sudo apt-get install qtcreator

enter image description here

5
  • Hi, thanks very much A.B. qtcreator is installed, and is using qt5. I can open one of their examples, but the design button on left sidebar stays greyed out. --Kate – KateF Jul 23 '15 at 19:49
  • I will check this tomorrow – A.B. Jul 23 '15 at 20:47
  • The button is only active, if there is a open ui-file. I will add a screenshot. – A.B. Jul 24 '15 at 16:39
  • Do you have /usr/lib/x86_64-linux-gnu/qt5/bin/designer on your system ? If so, could you do dpkg -S on it and let me know what pkg it came from ? – KateF Jul 24 '15 at 21:08
  • 1
    This is not what was asked for and doesn’t help user that use another or no idea at all. Plus it doesn’t even work if qttools5-dev-tools isn’t installed, so this basically boils down to @ptmono answer. – Peter Apr 6 '18 at 9:06
0

For anybody who is working on PyQT5 on NVIDIA Jetson Tegra X2 (TX2) running Ubuntu 16.04, this is the directory to find QT5 Designer:

/usr/lib/aarch64-linux-gnu/qt5/bin/designer
1
  • 2
    In my case: /usr/lib/x86_64-linux-gnu/qt5/bin/designer – danger89 Aug 4 '17 at 22:10
0

I was doing:

sudo apt-get install qttools5-dev-tools

I was not getting any results so instead I tried this and it worked:

sudo apt-get install qttools5-dev

This little difference has supposed some hours for me, I hope this post will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.