How to install Arial font in Ubuntu?

I found many ways to install fonts in Ubuntu but I didn't find any proper way or method to install (particularly) Arial fonts in Ubuntu.

  • 3
    sudo apt-get install ttf-mscorefonts-installer
    – A.B.
    Jul 22, 2015 at 18:52

6 Answers 6


Simply run

sudo apt install ttf-mscorefonts-installer
sudo fc-cache -f

in a terminal.

After that, check with

fc-match Arial
  • 3
    sudo apt install fontconfig for sudo fc-cache -f and fc-match Ariel commands.
    – user2942
    Sep 21, 2021 at 10:06
  • See @barsmaga solution below... One may need to accept EULA before installing the fonts, to make this work. echo "ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true" | sudo debconf-set-selections and then sudo apt-get install -y ttf-mscorefonts-installer --reinstall Sep 8, 2023 at 16:31
  • Thanks. This works on 22.04. Sep 22, 2023 at 21:05

Since the ttf-mscorefonts-installer mechanism mentioned in the accepted answer is still broken in Ubuntu 18.04 and I could not find a suitable mirror server for it to fix it, I propose to use this manual mechanism instead to install the very same fonts:

  1. Install cabextract, a tool needed to unpack self-extracting .exe archives:

    sudo apt install cabextract
  2. Download the font package provided via this page (also note the EULA there):

    wget https://www.freedesktop.org/software/fontconfig/webfonts/webfonts.tar.gz
  3. Unpack, twice:

    tar -xzf webfonts.tar.gz
    cd msfonts/
    cabextract *.exe
  4. Move the fonts to your user's directory for installing additional fonts:

    cp *.ttf *.TTF ~/.local/share/fonts/
  5. Restart the software in which you want to use the fonts, and they should be ready to use.

  • 4
    This works on Ubuntu 18.04. Just before you run cp *.ttf *.TTF ~/.local/share/fonts/, make sure you create or have /font directory there.
    – MAPK
    Feb 25, 2019 at 20:44
  • Working on Ubuntu 19.04 in as well.
    – jfaccioni
    Nov 8, 2019 at 14:27

I have been getting LiberationSans-Regular.ttf: "Liberation Sans" "Regular" for sudo fc-match Arial

So I tried following to make it work :

1) Create directory to download fonts to: sudo mkdir ~/ms-fonts/

2) cd ~/ms-fonts/

3) Download fonts manually :

wget http://downloads.sourceforge.net/corefonts/andale32.exe
wget http://downloads.sourceforge.net/corefonts/arial32.exe
wget http://downloads.sourceforge.net/corefonts/arialb32.exe
wget http://downloads.sourceforge.net/corefonts/comic32.exe
wget http://downloads.sourceforge.net/corefonts/courie32.exe
wget http://downloads.sourceforge.net/corefonts/georgi32.exe
wget http://downloads.sourceforge.net/corefonts/impact32.exe
wget http://downloads.sourceforge.net/corefonts/times32.exe
wget http://downloads.sourceforge.net/corefonts/trebuc32.exe
wget http://downloads.sourceforge.net/corefonts/verdan32.exe
wget http://downloads.sourceforge.net/corefonts/webdin32.exe

4) sudo dpkg-reconfigure ttf-mscorefonts-installer and follow instructions. When asked, use full path to directory where fonts were downloaded i.e. /home/root2/ms-fonts/

5) sudo fc-cache

6) Check if installation is done successfully or not : sudo fc-match Arial

Hope this helps.

  • you can simple download those files and extract and move all .ttf files to ~/.local/share/fonts directory
    – Alex Jones
    Sep 3, 2018 at 18:57
  • btw the above answer did not work on elementary os 0.4.1 based on ubuntu 16.04
    – Alex Jones
    Sep 3, 2018 at 18:58
  • The only method that works for me on Ubuntu 22.04 Jul 5, 2022 at 23:33

I search for a solution for similar problems when preparing the docker file.

When you install fonts with the same command:

DEBIAN_FRONTEND="noninteractive" apt-get -y ttf-mscorefonts-installer

A license agreement is not applied and Arial and other fonts are not installed!

You can use this solution:

echo "ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true" | debconf-set-selections
apt-get install -y ttf-mscorefonts-installer

And you can check the result with the command:

fc-match Arial 
  • 1
    Thanks a lot! This finally resolved my problem! echo "ttf-mscorefonts-installer msttcorefonts/accepted-mscorefonts-eula select true" | sudo debconf-set-selections sudo apt-get install -y ttf-mscorefonts-installer --reinstall fc-match Arial Sep 8, 2023 at 16:29
  • 1
    I can cofirm that my problem was originally solved by @barsmanga's answer. However, it came back again and was then solved by @igormcoelho's suggestion to use --reinstall
    – Patrick
    Oct 4, 2023 at 15:33

The ttf-mscorefonts package mentioned in the other answers contains a very limited selection of fonts, and rather outdated versions of them.

To get a better selection of up-to-date fonts, you can instead rip them from a Windows installation. Microsoft itself provides free virtual machine images of Win 11, ostensibly for "testing sites on MS Edge", which you can use for this.

Distributing fonts obtained this way is probably illegal, but using them yourself may or may not be be fine.

  1. Get an image here, select "VirtualBox".

    The filenames below will be different depending on the VM image version.

  2. unzip WinDev2301Eval.VirtualBox.zip - this might take a while

  3. tar -xf 'WinDev2301Eval.ova' - this might take a while

  4. sudo apt install libguestfs-tools
    sudo mkdir /mnt/foo
    sudo guestmount -a 'WinDev2301Eval-disk001.vmdk' -i --ro /mnt/foo
    sudo cp -r /mnt/foo/Windows/Fonts/ .
    sudo umount /mnt/foo
    sudo rm -r /mnt/foo
    sudo mv Fonts WindowsFonts

Now you should have a WindowsFonts directory in the current directory, containing all the fonts you want.

  • To install them for all users, copy it to /usr/local/share/fonts.

  • To install it just for yourself, run sudo chown -R "$USER:$USER" WindowsFonts to change the owner to yourself, then copy the directory to ~/.local/share/fonts/.


Do following steps:

  1. Open software manager if its mint or Ubuntu software center if you are using Ubuntu
  2. Search for ttf-mscorefonts
  3. Install it
  • Can't confirm this answer for Ubuntu 19.04
    – MERose
    Jan 28, 2020 at 20:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .