15

This morning appeared update message so I upgraded version 43.0.2357.134-1 to 44.0.2403.89-1 and happens to any of the following:

By opening and loading chrome ubuntu crashes. By right-clicking the menu appears in black and Ubuntu crashes. Opening any menu, submenus may appear in black and then Ubuntu crashes.

Uninstall the program and installed it again but the problem persists.

  • 2
    I'm experiencing exactly what you describe – Michael Bylstra Jul 23 '15 at 0:30
  • 4
    A colleague at work experienced this today and wasn't sure if it was due to the Chrome update. Then I used apt-get on my machine to upgrade from Chrome 43 to 44, which promptly produced the same symptoms: black context menus and, within 10 seconds, the machine locked up. After ten minutes I powered it off, restarted and installed Chromium 43 as a fallback. Amazed that such a serious problem has passed testing unnoticed... – Desty Jul 23 '15 at 3:17
  • 1
    Please post an answer stating how you solved the issue, don't use the question or any comment.. – heemayl Jul 23 '15 at 21:17
12

normal user prompt I typed

google-chrome --disable-gpu

it worked and context menu showing up normal. Also under system chrome settings uncheck Use hardware acceleration when available option

| improve this answer | |
  • 2
    This is the best answer to actually resolve the issue. Other answers are either reverting Chrome to a previous version, or swapping video driver. The issue appears to be that Chrome now no longer disables GPU acceleration when Nouveau is being used, but using it is still unstable. Hence, disable on command-line chromium-browser --disable-gpu if you use Chromium. – Mike Aug 20 '15 at 9:59
5

SOLVED: During the upgrade apparently the X Server configuration (X.Org) was changed to the nouveau driver. Just change it to proprietary controller and Google Chrome stopped giving problems ... Thank you all for your responses. Regards.

| improve this answer | |
  • 1
    how do you fix this? – Tim Ogilvy Jul 28 '15 at 3:05
  • 1
    Can you post full instructions. What config to modify and how? – Ravish Bhagdev Jul 28 '15 at 8:18
  • 1
    In Ubuntu 14.04, I clicked on System Settings > Software & Updates > Additional Drivers and then clicked on an alternative to X.Org X server - Nouveau display driver. – ekawas Aug 11 '15 at 15:41
2

Had the same issue as the original poster. Here's what I did:

Have not had an issue since. Alternatively, I've seen some recommendations in situations like this to remove the stable package via Apt/Synaptic, purge the .config folder and then install it as if it were new. Either way, it's a lot of new log-ins and verification codes (if you have two-step verification) regardless.

So far so good for me. I hope this works for you.

| improve this answer | |
1

A temporary fix that that seems to have worked for me is running the following from the command line:

chrome-stable --disable-gpu

Note that you can't disable hardware acceleration using chrome://flags in the url bar, as it will crash once you do that!

| improve this answer | |
1

Based on Abraham Lopez' answer I did the following:

sudo lshw -C video

Result (take a look at the second last line @ configuration):

*-display            
description: VGA compatible controller
product: GF108GL [Quadro 600]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:59 memory:f9000000-f9ffffff memory:e0000000-e7ffffff memory:ee000000-efffffff ioport:9f00(size=128) memory:e8000000-e807ffff

Then I did:

sudo apt-get --purge remove xserver-xorg-video-nouveau

Followed by:

sudo apt-get install nvidia-331 nvidia-331-updates -f

After a reboot, I ran sudo lshw -C video again:

*-display            
description: VGA compatible controller
product: GF108GL [Quadro 600]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:03:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:59 memory:f9000000-f9ffffff memory:e0000000-e7ffffff memory:ee000000-efffffff ioport:9f00(size=128) memory:e8000000-e807ffff

This answer has been written on Chrome 44.0.2403.125 which and it apparently didn't crash...

| improve this answer | |
1

Based on Abraham Lopez's answer I did the following using the ubuntu 14.04 gui:

System settings/Software & Updates/Additional Drivers Tab

Then select "Using NVIDIA binary driver - version 331.113 from nvidia-331 (proprietary, tested)"

Will take a while to download but corrected the problem.

| improve this answer | |
0

I did everything in this guide but none worked. Apparently the Ubuntu 14.04 that I am using has an older NSS library. I needed to update the files, and then upgrade the libnss-3 library in order to get chrome to start. However, chromium does not utilize these files, so no issues with chromium. Do this if you have Ubuntu 15 or lower.

Do this:

  1. sudo apt-get update
  2. sudo apt-get install --only-upgrade libnss3
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.