14

Trying to resolving the bug for KWORKERS HIGH CPU, as suggested in this answer. I put in my crontab the row:

@reboot echo "disable" > /sys/firmware/acpi/interrupts/gpe06

After the reboot, the system doesn't start. Also in single user mode it doesn't start.

I rebooted my PC with the option:

init=/bin/bash

and I removed the row in the root crontab but the system doesn't start.

2
  • 1
    add the full path of echo command. $ which echo /bin/echo So : sudo crontab -e Then add the line: @reboot /bin/echo "disable" > /sys/firmware/acpi/interrupts/gpe06
    – Maythux
    Jul 22, 2015 at 11:05
  • 2
    Did you add that line to your crontab or to root's? What bug are you talking about? What is wrong with your system? What are the symptoms? "It doesn't start"? OK, where does it stop? Does it not even turn on? Is the screen black? Pleaseedit your question and give us the information needed to answer it.
    – terdon
    Jul 22, 2015 at 11:25

3 Answers 3

1

The simplest method to do a programmed reboot (although I can't think of a use case), is to create a simple script file like so:

(shebang)/bin/bash
sudo init 6

And schedule it as a normal cron job using

crontab -e

(back to the old school way)

0

My understanding is that @reboot jobs are not run as this is a bug: https://unix.stackexchange.com/questions/109804/crontabs-reboot-only-works-for-root

-2

Use sudo to run @reboot - 14.04 uses initd instead of systemd and initd requires root / sudo to reboot, while systemd does not.

2
  • The question isn't about how to run reboot. Mar 3, 2018 at 7:43
  • 14.04 uses Upstart. No idea what initd is.
    – muru
    Mar 3, 2018 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.