1

I'm having difficulty connecting to my building's wifi network after I installed Ubuntu 14.04 on my Surface 1 Pro. Based on the "Network Connections", it looks like my network has the following settings:

Security: WPA & WPA2 Enterprise
Authentication: TTLS
Inner authentication: MSCHAPv2

I have added the output from lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation 3rd Gen Core processor DRAM Controller [8086:0154] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation HM77 Express Chipset LPC Controller [8086:1e57] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e03] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller [8086:1e22] (rev 04)

Thanks in advance, I appreciate the help

EDIT: Adding logs from syslog

Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) starting connection '<MyNetwork>'
Jul 21 10:26:11 surface NetworkManager[783]: <info> (mlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Jul 21 10:26:11 surface NetworkManager[783]: <info> NetworkManager state is now CONNECTING
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) Stage 1 of 5 (Device Prepare) started...
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) Stage 2 of 5 (Device Configure) scheduled...
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) Stage 1 of 5 (Device Prepare) complete.
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) Stage 2 of 5 (Device Configure) starting...
Jul 21 10:26:11 surface NetworkManager[783]: <info> (mlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0/wireless): connection '<MyNetwork>' has security, and secrets exist.  No new secrets needed.
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'ssid' value '<MyNetwork>'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'scan_ssid' value '1'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'key_mgmt' value 'WPA-EAP'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'auth_alg' value 'OPEN'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'password' value '<omitted>'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'eap' value 'TTLS'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'fragment_size' value '1300'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'phase2' value 'auth=MSCHAPV2'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'identity' value 'username'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'bgscan' value 'simple:30:-65:300'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'proactive_key_caching' value '1'
Jul 21 10:26:11 surface NetworkManager[783]: <info> Activation (mlan0) Stage 2 of 5 (Device Configure) complete.
Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: set interface ap_scan to 1
Jul 21 10:26:11 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: inactive -> scanning
Jul 21 10:26:11 surface wpa_supplicant[1155]: message repeated 2 times: [ mlan0: CTRL-EVENT-SCAN-STARTED ]
Jul 21 10:26:15 surface wpa_supplicant[1155]: mlan0: Trying to associate with <MAC> (SSID='<MyNetwork>' freq=5785 MHz)
Jul 21 10:26:15 surface wpa_supplicant[1155]: mlan0: Associated with <MAC>
Jul 21 10:26:15 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: scanning -> associating
Jul 21 10:26:15 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: associating -> associated
Jul 21 10:26:15 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
Jul 21 10:26:15 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25 -> NAK
Jul 21 10:26:15 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-EAP-FAILURE EAP authentication failed
Jul 21 10:26:17 surface wpa_supplicant[1155]: mlan0: Authentication with <MAC> timed out.
Jul 21 10:26:17 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-DISCONNECTED bssid=<MAC> reason=3 locally_generated=1
Jul 21 10:26:17 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="<MyNetwork>" auth_failures=1 duration=10
Jul 21 10:26:17 surface wpa_supplicant[1155]: nl80211: Was expecting local disconnect but got another disconnect event first
Jul 21 10:26:17 surface NetworkManager[783]: <warn> Connection disconnected (reason -3)
Jul 21 10:26:17 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: associated -> disconnected
Jul 21 10:26:17 surface NetworkManager[783]: <warn> Connection disconnected (reason 3)
Jul 21 10:26:17 surface kernel: [   60.139207] cfg80211: Calling CRDA to update world regulatory domain
Jul 21 10:26:17 surface kernel: [   60.141495] cfg80211: World regulatory domain updated:
Jul 21 10:26:17 surface kernel: [   60.141499] cfg80211:  DFS Master region: unset
Jul 21 10:26:17 surface kernel: [   60.141500] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Jul 21 10:26:17 surface kernel: [   60.141503] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
Jul 21 10:26:17 surface kernel: [   60.141504] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
Jul 21 10:26:17 surface kernel: [   60.141506] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
Jul 21 10:26:17 surface kernel: [   60.141507] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
Jul 21 10:26:17 surface kernel: [   60.141508] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
Jul 21 10:26:17 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SCAN-STARTED 
Jul 21 10:26:17 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: disconnected -> scanning
Jul 21 10:26:26 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SCAN-STARTED 
Jul 21 10:26:29 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="<MyNetwork>"
Jul 21 10:26:29 surface wpa_supplicant[1155]: mlan0: Trying to associate with <MAC> (SSID='<MyNetwork>' freq=5785 MHz)
Jul 21 10:26:29 surface wpa_supplicant[1155]: mlan0: Associated with <MAC>
Jul 21 10:26:29 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
Jul 21 10:26:29 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: scanning -> associating
Jul 21 10:26:29 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25 -> NAK
Jul 21 10:26:29 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-EAP-FAILURE EAP authentication failed
Jul 21 10:26:29 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: associating -> associated
Jul 21 10:26:31 surface wpa_supplicant[1155]: mlan0: Authentication with <MAC> timed out.
Jul 21 10:26:31 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-DISCONNECTED bssid=<MAC> reason=3 locally_generated=1
Jul 21 10:26:31 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="<MyNetwork>" auth_failures=2 duration=20
Jul 21 10:26:31 surface NetworkManager[783]: <warn> Connection disconnected (reason -3)
Jul 21 10:26:31 surface wpa_supplicant[1155]: nl80211: Was expecting local disconnect but got another disconnect event first
Jul 21 10:26:31 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: associated -> disconnected
Jul 21 10:26:31 surface NetworkManager[783]: <warn> Connection disconnected (reason 3)
Jul 21 10:26:31 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SCAN-STARTED 
Jul 21 10:26:31 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: disconnected -> scanning
Jul 21 10:26:37 surface NetworkManager[783]: <warn> Activation (mlan0/wireless): association took too long.
Jul 21 10:26:37 surface NetworkManager[783]: <info> (mlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Jul 21 10:26:37 surface NetworkManager[783]: <warn> Activation (mlan0/wireless): asking for new secrets
Jul 21 10:26:37 surface NetworkManager[783]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Jul 21 10:26:37 surface NetworkManager[783]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Jul 21 10:26:40 surface NetworkManager[783]: <info> (mlan0): supplicant interface state: scanning -> inactive
Jul 21 10:26:57 surface NetworkManager[783]: <warn> No agents were available for this request.
Jul 21 10:26:57 surface NetworkManager[783]: <info> (mlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Jul 21 10:26:57 surface NetworkManager[783]: <info> NetworkManager state is now DISCONNECTED
Jul 21 10:26:57 surface NetworkManager[783]: <info> Marking connection '<MyNetwork>' invalid.
Jul 21 10:26:57 surface NetworkManager[783]: <warn> Activation (mlan0) failed for connection '<MyNetwork>'
Jul 21 10:26:57 surface NetworkManager[783]: <info> (mlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Jul 21 10:26:57 surface NetworkManager[783]: <info> (mlan0): deactivating device (reason 'none') [0]
Jul 21 10:26:57 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SCAN-STARTED 
Jul 21 10:27:01 surface wpa_supplicant[1155]: mlan0: Reject scan trigger since one is already pending
Jul 21 10:27:24 surface wpa_supplicant[1155]: mlan0: CTRL-EVENT-SCAN-STARTED 
6
  • This might be your problem: askubuntu.com/q/287804/32034 Commented Jul 22, 2015 at 3:33
  • That line doesn't appear anywhere in my file
    – Jrom
    Commented Jul 22, 2015 at 3:36
  • 1
    Share your WiFi logs from syslog. That'll probably show where the issue is Commented Jul 22, 2015 at 3:37
  • Added to original post
    – Jrom
    Commented Jul 22, 2015 at 3:50
  • Ok. So I got it working. Thank you for making me post the logs. I would not have found the issue otherwise :). I found this line: "Jul 21 10:26:11 surface NetworkManager[783]: <info> Config: added 'key_mgmt' value 'WPA-EAP'". I changed my authentication to "Protect EAP (PEAP)" and I was able to connect.
    – Jrom
    Commented Jul 22, 2015 at 4:04

1 Answer 1

0

When connecting to the network, I was using the default authentication scheme (TTLS). The issue was resolved after I changed the scheme to "Protect EAP (PEAP)"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .