6

I just swapped to Ubuntu 14.04 from Arch. I was installing some pentest tools from kali, the issue I'm having is when I run:

sudo wash -i mon0 -c 6

It has no output I'm only shown:

$ sudo wash -i mon0 -c 6

Wash v1.5.2 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>
mod by t6_x <t6_x@hotmail.com> & DataHead & Soxrok2212 & Wiire & kib0rg

BSSID              Channel  RSSI  WPS Version  WPS Locked  ESSID
-------------------------------------------------------------------------------------  

$  

I am using a Alfa AWUS036H with rtl8187 chipset, wireless usb card. The card is in monitor mode, here is the output for iwconfig:

$ sudo iwconfig
eth0      no wireless extensions.

mon0      IEEE 802.11bg  Mode:Monitor  Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on

lo        no wireless extensions.

wlan1     IEEE 802.11bg  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off

I installed all the updates after installation. I added the Kali repositories and installed aircrack-ng and many other tools. Some of the tools I compiled and installed because the ones linked in the raring repository are out dated. Also installed pixiewps and the updated reaver with the pixie dust attack. Shortly after installing everything I ran the update once more and restarted.

After all that I went to test and the first thing I notice was the wash command shows no output and quickly exits. What would cause this on Ubuntu, didn't have this issue on Arch or kali. I thought maybe my test network picked it up again and switched channels on me like it did in the past but it didn't.

I also ran the wash command without specifying any channels to see if it was just my network not showing but it doesn't display any neighboring routers either.

7

Another issue is that wash uses the directory /etc/reaver which is not created automatically. If wash shows an empty output check if the directory exists, if not mkdir /etc/reaver.

2
  • 2
    This worked for me after trying the answer from @jude and still getting the same
    – phocks
    Feb 8 '17 at 22:00
  • excellent, party on dude!
    – fie
    Oct 6 '19 at 6:28
3

i found the answer here https://forum.aircrack-ng.org/index.php?topic=666.0

this is not a reaver problem. This is output:libpcap0.8:i386 1.5.3-2, does not work for reaver/wash and must be downgraded to libpcap0.8:i386 1.4.0-2.

wget http://mirror.esc7.net/pub/Ubuntu/pool/main/libp/libpcap/libpcap0.8_1.4.0-2_i386.deb

dpkg -i libpcap0.8_1.4.0-2_i386.deb restart mon0/wlan0mon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.