I have a regular ubuntu installation which I then installed xubuntu desktop over. I am occasionally confounded though by an unknown "screen locker" that occasionally appears instead of my normal locker. For example, when my screen saver comes on, and I move the mouse, I am confronted with the following (notice there's a switch user and unlock button):

enter image description here

On the other hand, occasionally (about 1 in 5 times - the other times I get a 'normal' box), especially after "suspending" (by closing the lid), and waking up the computer, I am confronted with the following:

enter image description here

note the red border on the password box, and the lack of a 'switch user' button.

When I have the second box I am unable to unlock the computer. No matter what password I use, my user password, etc. it will just not unlock. I have to go to a console (Ctrl-Alt-1) and then reboot the computer.

In the past, from the console, I have killed all processes with "screen" in the name, nothing helps.

What is this "broken" locker (so I an identify and remove it)? Which password does it expect (there is no root password, I am the only user on the machine - I have sudo access).

Any thoughts/insights appreciated.


I ran into the same issue in Xubuntu 15.10. LightDM starts up gnome-screensaver when the device goes into suspend at the lock/login screen.

Run the following to fix the issue:

sudo apt-get remove gnome-screensaver 
  • This worked for me in Lubuntu 16.04.1. – Roger Lipscombe Jun 29 '17 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.