5

I am a total noob in Ubuntu, and i would like to change the default directory of Documents, Music, Pictures etc. My setting is as follows:

  • 1 partition for Windows
  • 1 partition for ubuntu
  • 1 partition in NTFS format for Storage.
    In that particular partition I store the Documents, Pictures etc for Windows.

Now I would like to make the exact same folders that store these stuff in Windows, to store the same stuff in Ubuntu as well. I used the tips I found in one post here, mentioning how to change the lines like this in ~/.config/user-dirs.dirs

XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_MUSIC_DIR="/home/common/Music"
XDG_VIDEOS_DIR="$HOME/Movies"

and indeed it works fine, but every time I restart the machine, it's reset to simple "$Home/", without pointing to any actual directory. I mean that if I open the Documents folder, it takes me to an empty folder.

What is it that I'm doing wrong? How can I fix it? Many thanks in advance. (I use 14.04)

my fstab looks like that:

enter image description here

The terminal on the right side has the dev6, which is the partition i want to assign the Home folder to

  • what is the exact content of your $HOME/.config/user-dirs.dirs file ? Please, edit your post. Does this content change after a reboot ? How do you mount your NTFS partition ? may be it's mounted too late during boot or login. That could be why. – solsTiCe Jul 21 '15 at 13:24
  • 2
    You do have to have partition mounted or it will not recognized different settings. And clicking on partition may auto mount it, but that is too late. You need to add to fstab so auto mounted during boot. I prefer linking which is another way to do it. ubuntuforums.org/showthread.php?t=1811198 – oldfred Jul 21 '15 at 13:34
  • This might be the case, oldfred. But like i said, it's my first time in Ubuntu and i probably need a step by step guidance. :) If you'd be so kind, please guide me. Here is the xdg text after i edit it: dl.dropboxusercontent.com/u/30353620/screen1.png and here it is after the restart. dl.dropboxusercontent.com/u/30353620/screen3.png, dl.dropboxusercontent.com/u/30353620/screen4.png – Odette Jul 22 '15 at 13:22
  • I downloaded Ubuntu tweak and it's supposed to be set to automount the disks... but the same thing happens every time i reboot. I don't know if i need to do it manually. If so, please tell me how. Thank you. – Odette Jul 22 '15 at 13:24
  • What is the content of /etc/fstab. Edit your question above with that. – solsTiCe Jul 23 '15 at 11:53
0

You can add a line in your etc/fstab

/dev/sda6 /media/basislis/Storage ntfs rw,users,nosuid,nodev,default_permissions

This should automatically mount your NTFS share at boot and should normally fix the problem.

You may have to tweak the mount option. Look for documenation on that and educate yourself.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.