I installed a CLI system with Ubuntu 11.10 Beta 2 Alternate CD. Then installed Ubuntu Desktop (--no-install-recommends). After a restart, it hangs at the below screen

enter image description here

Whats wrong?

Btw: I notice a CLI system will NOT boot in by default (even in 11.04), I must go recovery mode and update grub then resume boot. This happens even when there are GRUB entries for the OSes already (though I am not sure if they are invalid or something). Another method is setting nomodeset


I used edited the boot entry to include text nomodeset. Then I got a full log with 1 fail

enter image description here

Maybe I missed a package since I installed Ubuntu Desktop with no-install-recommends

UPDATE 2: With Ubuntu 11.10 Stable

I just installed Ubuntu 11.10 Stable (CLI System) then installed ubuntu-desktop --no-install-recommends. startx to boot into Ubuntu Desktop OK. but reboot and got stuck on the above screen

Tried: Boot into recovery, Update GRUB, Resume got:

Tried booting into Ubuntu 11.10 but with text nomodeset in GRUB got similar as above

  • please paste all this command -> What does sudo fdisk -l show?, paste your fstab and execute sudo blkid... – hhlp Oct 22 '11 at 9:22
  • also ls -l /dev/disk/by-uuid/ – hhlp Oct 22 '11 at 10:03

Hm. From those screenshots it looks like the display manager (LightDM) thinks it's starting but is not switching VT properly (or possibly not starting properly at all). It's not clear whether you've tried Ctrl+Alt+F7 to switch to the VT that lightdm will be starting on.

The logs in /var/log/lightdm/lightdm.log might be helpful in working out what's happening. Note: these may contain some identifying information, like your local username.

It's possible that either installing plymouth-theme-ubuntu-logo or adding vt.handoff=7 to your grub kernel boot commandline would fix this.

Either way, this looks like you might have hit a bug.

| improve this answer | |

Try booting with the noacpi option, as well as both noacpi and nomodeset. There seems to be something about the ACPI initialization that gets in the way of (even text mode) video. On a related note, I had to start the 11.10 installer in noacpi mode on my Thinkpad T420s to get it to start up properly, but after install everything works perfectly.

| improve this answer | |

It looks like an ACPI issue, but there are many steps to troubleshooting this properly. Take a look at the following wiki page and go through the steps.


This is a blog entry about what I had to do with my daughter's machine:


| improve this answer | |

Once you get all the [OK] can you just try to do a Ctrl+Alt+F1.

| improve this answer | |

I had the same problem with Ubuntu 11.10 server after installing ubuntu-desktop with the --no-install-recommends flag.

I solved it with:

apt-get install lightdm-gtk-greeter
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.