3

im trying to bind my spare radeon card to pci-stub on kubuntu 15.04, ive got this for my boot options

dmesg | grep pci-stub

[ 0.000000] Command line: BOOT_IMAGE=/vmlinuz-3.19.0-15-generic root=/dev/mapper/kubuntu--vg-root ro quiet splash pci-stub.ids=1002:6779,1002:aa98 vt.handoff=7

but later on in the output i get this

[ 4.349476] pci-stub: add 1002:6779 sub=FFFFFFFF:FFFFFFFF cls=00000000/00000000

[ 4.349485] pci-stub: add 1002:AA98 sub=FFFFFFFF:FFFFFFFF cls=00000000/00000000

[ 4.349504] pci-stub 0000:02:00.1: claimed by stub

i grepped for radeon in my dmesg output, and indeed its only claiming the sound output device and radeons taking the graphics device, anyone know what the hell is going on?

lspci | Radeon

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]

01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series]

02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]

02:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]

lspci -n | grep 02:00.

02:00.0 0300: 1002:6779
02:00.1 0403: 1002:aa98
  • Did you solve the problem? Happens the same on my machine. – Marcus Sep 17 '15 at 22:40
  • sadly no, i cant find any information on how to actually go about fixing it, although in fedora you can use dracut to load pci-stub before radeon by making radeon depend on pci-stub. dracut is available in ubuntu, but when i tried installing it it threatened to uninstall a bunch of stuff that id really rather not be without. – anon Sep 19 '15 at 3:53
2

This is happening because the radeon module is taking control of the device before pci-stub, so you need to reverse the load order.

Blacklist the radeon module:

$ echo blacklist radeon | sudo tee -a /etc/modprobe.d/blacklist.conf

And add the module to initramfs:

$ echo radeon | sudo tee -a /etc/initramfs-tools/modules
$ sudo update-initramfs -u

After, reboot. Problem solved!

  • ive got 2 AMD cards, and one of them needs to go to ubuntu, so blacklisting radeon isnt an option. as i mentioned above, dracut seems to be the answer to my problems, but it means ditching ubuntu, and thats a pain. – anon Sep 19 '15 at 3:54
  • I have two AMD cards too, but it works; blacklisting a module doesn't mean that the module can't be loaded at all - it means that it's not loaded automatically. The initrafms addition will load it. – Marcus Sep 20 '15 at 7:50
  • This worked for me, thank you. Also, is update update-initramfs a typo? – MatrixManAtYrService Dec 23 '15 at 22:01
  • If you refer to the update, yes, it was a typo! Thanks, I've fixed it! – Marcus Dec 24 '15 at 22:46
0

My fix to this was the steps indicated by Marcus but with the following changes:

Blacklist the radeon (amdgpu) module:

echo "blacklist amdgpu" | sudo tee -a /etc/modprobe.d/blacklist.conf

And then add the module to initramfs:

echo amdgpu | sudo tee -a /etc/initramfs-tools/modules

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.