2

I am new linux user and I have problem with my backlight. When I press the combination for turning it off, this appears on the screen.

enter image description here I use Ubuntu MATE 14.04

samuel@samuel-G551JK:~$ ls /sys/class/backlight
intel_backlight

Now it is disabled, when I enable it, I can't turn it off. It's off when on battery, not plugged in.

  • Please edit your question and add output of ls /sys/class/backlight terminal command. – Pilot6 Jul 20 '15 at 17:44
  • Can you increase/decrease brightness using buttons? – Pilot6 Jul 20 '15 at 17:48
  • No, nothing happens. – Samuel Shifterovich Jul 20 '15 at 17:51
  • But volume, touchpad, "make monitor black" works.. – Samuel Shifterovich Jul 20 '15 at 17:51
2

Run in terminal

sudo sed -i 's/quiet splash/quiet splash acpi_osi=/' /etc/default/grub
sudo update-grub

Then reboot. The keys must work.

You will probably need to create a file /usr/share/X11/xorg.conf.d/20-intel.conf with this content

Section "Device"
    Identifier  "card0"
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
    BusID       "PCI:0:2:0"
EndSection
| improve this answer | |
  • Seems like I don't have gedit, and my mouse sometimes goes crazy, but one touchpad click makes it normal. I'll use nano instead of gedit. – Samuel Shifterovich Jul 20 '15 at 17:58
  • I made all that text as a command. It does same. – Pilot6 Jul 20 '15 at 18:11
  • "The keys must work." That's an order! =) – A.B. Jul 20 '15 at 18:16
  • @SamuelShifterovich Common, give him an upvote, you have enough reps ;) – A.B. Jul 20 '15 at 18:17
  • Actually, I didn't have. :P – Samuel Shifterovich Jul 20 '15 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.