6

I have installed both openssl and openssl-dev, with these:

sudo apt-get install openssl
sudo apt-get install libssl-dev

And has install ffmpeg by these:

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get install ffmpeg

Now I would like to enable https protocol for ffmpeg. I did try these:

user@user-VirtualBox:~/ffmpeg_sources/ffmpeg$ ./configure --enable-openssl

And its listed in the Enabled protocols list.

After that ran these commands:

make
make install

But with no help. And if check the ffmpeg -protocols, the https protocols is not listed there.

I am using ubuntu inside a virtualbox, and I not very good at it. If you could please guide me through how to compile openssl with ffmpeg to enable https protocol I would be very thank grateful. Thank you.

2
  • Try /usr/local/bin/ffmpeg - also what is the output of whereis ffmpeg? Also, what version of ubuntu are you using?
    – Wilf
    Jul 20, 2015 at 15:02
  • You weren't actually using that ppa's ffmpeg as https was & continues to be enabled..
    – doug
    Sep 15, 2017 at 21:51

2 Answers 2

5

Add --enable-openssl, This is what I use. Make sure the library is inatalled, debian: sudo apt install libssl-dev, or redhat: yum install -y openssl-devel

PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure \
  --prefix="$HOME/ffmpeg_build" \
  --pkg-config-flags="--static" \
  --extra-cflags="-I$HOME/ffmpeg_build/include" \
  --extra-ldflags="-L$HOME/ffmpeg_build/lib" \
  --bindir="$HOME/bin" \
  --enable-gpl \
  --enable-libass \
  --enable-libfdk-aac \
  --enable-libfreetype \
  --enable-libmp3lame \
  --enable-libopus \
  --enable-libtheora \
  --enable-libvorbis \
  --enable-libvpx \
  --enable-libx264 \
  --enable-libx265 \
  --enable-openssl \
  --enable-nonfree
PATH="$HOME/bin:$PATH" make
make install
hash -r
3

TL;DR

./configure --enable-gnutls

Open a terminal and follow the commands below:

For Trusty you need a PPA, recommended on the ffmpeg download page

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update

After that

cd
apt-get source ffmpeg
sudo apt-get build-dep ffmpeg

Replace 2.5.7 with your version:

cd ffmpeg-2.5.7
./configure --enable-gnutls
dpkg-buildpackage -rfakeroot -uc -b

After that, install the package in the parent folder (cd ..).

7
  • There's not apt-get source ffmpeg
    – Robin
    Jul 22, 2015 at 15:42
  • @Robin what do you mean? ffmpeg is in the standard repositories.
    – A.B.
    Jul 22, 2015 at 15:45
  • Yes. I have no idea why. It should have been. But its not there.
    – Robin
    Jul 22, 2015 at 15:46
  • @Robin sorry, not for Trusty askubuntu.com/a/432585/367165
    – A.B.
    Jul 22, 2015 at 15:51
  • 1
    Out of curiosity, why do you prefer gnutls over openssl?
    – Elliott B
    Mar 17, 2021 at 0:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .