1

When logging in to ubuntu 14.04 I am encountering a login loop on my main account. Upon entering my password, the login box disappears to leave the wallpaper displaying alone. Then after maybe 1-2 minutes, the screen becomes black for a moment before returning to the login. I can still reach and log in to tty.

This is after weeks of grapics related issues that cropped up when I tried to change the nvidia graphics drivers, which resulted in a sporadic hanging on the splash screen on boot-up. This may be unrelated, but I feel it may be a compounding factor.

Notes:

  • I created a second, non-admin user, which can login fine and reach a working Unity session.

  • My main user account (se14) seems to have permissions for ~/.Xauthority and ~/.ICEauthority:

    se14@cdt001-lap:~$ ls -ld ~/.*authority
    -rwxrwxrwx 1 se14 se14 55110 Jul 20 15:07 /home/se14/.ICEauthority
    -rwxrwxrwx 1 se14 se14    55 Jul 20 15:07 /home/se14/.Xauthority
    
  • I have tried to switch to gdm via:

    sudo dpkg-reconfigure gdm
    

    but after choosing gdm when prompted this just gives a black screen with an underscore top-left when I reboot. I then have to go back into tty2 to switch to lightdm and reboot again.

  • I have tried uninstalling and reinstalling gdm, lightdm, xorg and even ubuntu-desktop.

  • My ~/.profile file was the default file. Still, I deleted it and rebooted axccording to advice I had seen in other threads. Nothing.

If anyone knows of anything more I can do, I'd greatly appreciate the effort. I'm not so great at ubuntu either, so specific commands in any answers would be hugely helpful.

Many Thanks

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.