3

If I feed url with http, such as this:

ffmpeg -i http://vjs.zencdn.net/v/oceans.mp4 videojs.mp4

It works perfectly. However, when I feed url with https, such as this:

ffmpeg -i https://s3-us-west-2.amazonaws.com/bucket/check.mp4 video.mp4

This gives me an error:

https protocol not found, recompile FFmpeg with openssl, gnutls, or securetransport enabled.
https://s3-us-west-2.amazonaws.com/bucket/check.mp4: Protocol not found

However the same commands works on my windows machine. I am using ubuntu inside a virtualbox and not very good at it.

What do I do to enable https? I suppose I should recompile ffmpeg with openssl? Please help me solve this. Your help will be very much appreciated. Thank you.

  • Are you using 15.04 or something older? – Thomas Ward Jul 20 '15 at 11:39
  • @ThomasW. No I am using 14.04 – Robin Jul 20 '15 at 11:50
  • 1
    ehh, 14.04 is... old enough that I think ffmpeg was broken... I'll poke at this and see if I can make it build as is in 15.04 and later... later, around my work break. – Thomas Ward Jul 20 '15 at 11:54
2

Very likely what's happening is that ffmpeg is compiled without SSL support in the version of Ubuntu you are using.

Whatever the reason for this, it's a headache, so the only solution you have left to rapidly fix this is to actually do a recompile.

Likely, when you build from source, you'll need to have a --with-openssl or similar option when you run a ./configure.


Note that for Ubuntu Wily, it appears they may already include this option in the packaging which is newer than for Vivid.

0

Just download ffmpeg from here and you will be fine. http://johnvansickle.com/ffmpeg/ It is build statically and does not need any dependency. Extract it into a folder and run it from that directory with ./ffmpeg ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.