1

I have Eclipse installed on my Ubuntu with Java 1.7. I need to compile binary code for Java 1.4.

How to install second Java 1.4 on my Ubuntu since 1.7 I need to run Eclipse.

  • You probably do not want to install JDK 1.4 to do this. The correct approach would be to set the binary level of your project to 1.4 in Eclipse, and continue to use a modern (still supported) JDK. – trognanders Jul 20 '15 at 9:21
0

You don't need a second Java version. Open your project settings

  • Right Click on project
  • Select Properties
  • In the dialog set the compiler compliance level to 1.4.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.