I am running Natty Narwhal on a Dell Vostro (I don't know the model number). The machine will hang (freeze) hard a random time (0-5 minutes) after I either remove the AC power cable or disable wifi using the switch at the front of the machine.

Here are some details:

  • Hard freeze means even the mouse cursor doesn't move. I can't switch virtual terminals using "CTRL+ALT Fn".
  • I have not tried to ssh in from another machine, or using a serial console.
  • This is independent of the graphics driver (it's an nvidia card)
  • It's a Broadcom card, but I have NOT tried the proprietary drivers (wifi works)
  • If both AC power and wifi are on, but I switch off the wifi, it will soon hang.
  • If I boot up without the AC power, it will hang within a few minutes of boot
  • If I boot up with the wifi switched off, it will NOT hang, unless I pull out the AC power.

The frustrating thing is that last week I googled around and found someone with very similar problems (and they had a solution) but now I can't find it again. This person claimed that his machine also didn't crash if he plugged in an ethernet cable, and then unplagged the AC power. I have not tested this.

After pulling out the AC power, there is no change to the outputs of

  • lspci -nnvv,
  • lsmod, or
  • iwconfig.

Unless someone asks, I will not pollute this site with the complete output of all these commands; here is a selection:

iwconfig (full output):

lo        no wireless extensions.

eth0      no wireless extensions.

vboxnet0  no wireless extensions.

virbr0    no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:off

lspci -nnvv (only the broadcom secton)

12:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
    Subsystem: Dell Device [1028:0010]
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 17
    Region 0: Memory at fb400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: brcm80211
    Kernel modules: brcm80211

lsmod | grep 211

    brcm80211             748941  0 
    mac80211              294370  1 brcm80211
    cfg80211              178528  2 brcm80211,mac80211

My DELL Vostro 3700 behaved very similarly last weeks. I've solved these issues today, after having installed 3.0.0-13-generic kernel. So, try to:

  • pass pcie_aspm=off to kernel (edit /etc/default/grub and run update-grub);
  • install Broadcom's STA driver which works great while on battery also.

Hope this helps you too.

Well, I have got my wired network with me while reinstalling BTA's drivers.

FYI, now I have GRUB_CMDLINE_LINUX="acpi_osi=Linux pcie_aspm=off" in /etc/default/grub.

  • My Dell Vostro 3700 running 12.04 64-bit suddenly freezes (permanently, without any log messages) with or without wifi (using STA driver), when running on battery. I've added GRUB_CMDLINE_LINUX="acpi_osi=Linux pcie_aspm=off" and will report back.
    – Graham
    Nov 12 '12 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.