My dual boot Ubuntu/Windows installation on a Samsung Series 7 laptop is suddenly broken, I do not know why. I have not made an update, and the laptop was not even connected to the internet when it was on last time it worked. It uses Windows 8 and Ubuntu (14.04 or older if I remember correctly). I am stuck right at the grub rescue prompt where you can do nothing much except ls. The error message on the top of the sceeen which is followed by a grub rescue> prompt is

error symbol 'grub_term_highlight_color' not found
grub rescue>

If I make ls I get

(hd0) (hd0,gpt9) (hd0,gpt8) (hd0,gpt7) (hd0,gpt6).. (hd0,gpt1) (hd1) (cd0)

The gpt entries seem to indicate the GUID Partition Table (GPT) entries for the Ubuntu partitions. (hd0,gpt8)/ seems to be the root partition with the linux folders and has a subdirectory boot/grub. But if I try to boot linux manually I get still the same error

grub rescue> set prefix=(hd0,gpt8)/boot/grub
grub rescue> set root=(hd0,gpt8)/
grub rescue> insmod normal
error: symbol 'grub_term_highlight_color' not found

Booting from Ubuntu Live CD or Super Grub2 Disk on CD is not possible, the system does not recognize any CD or DVD. Booting from USB is also not possible. Argh. Help.


Standard repair procedure with rescuing from boot CD/USB stick (with any Linux distribution):

sudo -s
mkdir /mnt/disk
mount /dev/sda3 /mnt/disk # use sdXY where your root partition is
mount --bind /dev /mnt/disk/dev
mount --bind /sys /mnt/disk/sys
mount --bind /proc /mnt/disk/proc
chroot /mnt/disk

delete old files from /boot, in my case I had there outdated afi-3.11* files

# press Ctrl + D

Now, grub should normally boot.

In case you need EFI, have a look at similar question.

| improve this answer | |

Ok, I was able to start from CD by pressing F10 at the beginning to enter the BIOS. Then I was able to boot Ubuntu using the Super Grub Disk, updated the Boot-Repair program and started it. I had to run Boot-Repair several times (2 or 3 times). The EFI/UEFI stuff caused problems again, but at least I can boot it again now.

Update: The reason could have been the recent update to Ubuntu 14.04. https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1289977/+index?comments=all The Windows 8 version from the dual book system still does not boot :-(

| improve this answer | |
  • Did this fix the problem, or is it still failing for you? – Rod Smith Jul 19 '15 at 20:24
  • I update the answer. The Super Grub Disk was helpful to start the system again, and Boot-Repair is useful to repair the Grub setup. – 0x4a6f4672 Jul 20 '15 at 11:34
  • Urgs, now Windows 8 no longer boots, do you have an idea @RodSmith ? Boot Repair says paste2.org/z0Nyfffy – 0x4a6f4672 Jul 21 '15 at 21:59
  • Try booting Ubuntu and doing a sudo update-grub. If that doesn't work, see if the USB flash drive or CD-R version of my rEFInd boot manager will boot both Windows and Ubuntu. If the rEFInd USB flash drive or CD-R works, you could install the PPA or Debian package to your hard disk. This will bypass GRUB, which can be finicky sometimes. – Rod Smith Jul 22 '15 at 1:07
  • Hmmh, sudo update-grub does not help :-( – 0x4a6f4672 Jul 24 '15 at 19:59

I have a dual boot with Ubuntu 15.04 and Windows 8. I encountered this issue while i was booted up on windows for a couple of hours, my laptop restarted on its own and showed this grub rescue prompt with 'grub term highlight color not found' error.

I came across several posts on this issue, which had primarily suggested running boot repair. I booted up the system with live ubuntu 15.04 USB, tried to install boot-repair with no success. I then went on to erase and reinstall ubuntu. But to my despair, when i restarted after installation, the grub rescue prompt came up again.

What worked for me was changing the Boot Option priority in BIOS. My SSD was earlier assigned as the 1st option, i choose the regular HD as the 1st option and restarted.

Voila! i was able to boot into Ubuntu directly - with no boot menu!! Came across this post - Dual boot pc boots directly to ubuntu instead of showing grub menu Updated grub file to comment GRUB_HIDDEN_TIMEOUT=0, updated grub and restarted. And i have my laptop back to normal with a boot menu and everything back!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.