5

I have an Acer Aspire V5 Notebook with Ubuntu 14.04 installed on a SSD an Windows 8.1 on a HDD.

I experience that my Notebook wakes up from standby randomly after a certain time (can be a few seconds, minutes or some 10 hours). This only happens in Ubuntu, Windows 8.1 is not affected. I cannot find a pattern under which situations the hibernation is interrupted. It happens if the hibernate/standby is induced by closing the lid or using the software button for standby.

Another issue which might be related is that i cannot select "hibernate" as the low battery action in the power section. It is greyed out. I am not sure if this has anything to do with my problem, I just wanted to mention it in case there is a connection.

This behaviour is potentially dangerous for the hardware: when I carry my notebook in a bag and it turns itself on, it can cause heat accumulation in the bag and the device might get damaged from overheating.

As the wake up does not always appear (in 80% percent of all standby phases, I would guess) the debugging is non trivial.

Output of uname -a: Linux LappII 3.16.0-43-generic #58~14.04.1-Ubuntu SMP Mon Jun 22 10:21:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

EDIT: This behaviour might be related to this bug: Launchpad

I changed all entries in /etc/acpi/wakeup to disabled but this had no effect.

5
  • Try to update the kernel, this worked to me. askubuntu.com/questions/119080/… – Marcos Silveira Jul 28 '15 at 17:42
  • @MarcosRocha What do you mean with "this worked to me"? Did you experience the same problem and updating to a mainline kernel helped? Which specific kernel did you choose? And considering this answer askubuntu.com/a/162617/317977, installing a mainline kernel can cause lots of trouble. So can you expand your comment a bit, please? – Merlin1896 Jul 28 '15 at 18:46
  • I had the same problem, with other hardware (Asus motherboard), but when I upgraded the kernel to 3.18 this problem over. I can suspend or hibernate the PC and this not turn on until a mouse click or press any key. – Marcos Silveira Jul 28 '15 at 18:54
  • Have you checked askubuntu.com/questions/152256/… ? Seems a spurious wakeup event around... – Rmano Aug 1 '15 at 11:44
  • Are you saying that lightdm causes the wake ups and I should switch to gdm? – Merlin1896 Aug 1 '15 at 12:06
0

I would try suspending (standby) with this command:

dbus-send --system --print-reply \ --dest="org.freedesktop.UPower" \ /org/freedesktop/UPower \ org.freedesktop.UPower.Suspend

Change Suspend to Hibernate if you want to hibernate instead

I would probably create an alias in ~/.bashrc such as alias standby="dbus-send --system --print-reply \ --dest="org.freedesktop.UPower" \ /org/freedesktop/UPower \ org.freedesktop.UPower.Suspend"

Note that the mentioned commands don't require superuser privileges.

1
  • Well, this wouldn't fix the problem if i close the lid of my notebook, right? – Merlin1896 Jul 31 '15 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.