11

Ever since installing Bless Hex Editor, all unknown files and text files automatically open with Bless instead of gedit. How do I change it back? I don't want to have to manually associate files with gedit, I just want gedit to be the default if there's no other application set up to open the file.

Solution:
modify ~/.local/share/applications/mimeapps.list

[Default Applications] 
- text/plain=bless.desktop
- application/octet-stream=bless.desktop
+ application/octet-stream=gedit.desktop
6
  • Can you post the contents of /usr/share/applications/defaults.list and ~/.local/share/applications/mimeapps.list on paste.ubuntu.com ?
    – imgx64
    Oct 14 '11 at 12:39
  • mimeapps.list defaults.list was just replaced with the distro default after upgrading to 11.10. I can see the bless entries entries there. Can I just delete them to revert back to the system default?
    – dmuir
    Oct 17 '11 at 5:45
  • to answer my own question, yes, deleting the offending lines from mineppas.list fixes things. Firefox is still wanting to open stuff with bless though...
    – dmuir
    Oct 17 '11 at 6:19
  • That's odd, Firefox seems to use the system settings on my computer. Did you try restarting the computer (or restarting Firefox) after deleting the bless entries in mimeapps.list?
    – imgx64
    Oct 17 '11 at 15:57
  • Ah, fixed it. The problem was that there is no default for application/octet-stream, so it was using bliss as it existed under "Added Association". So to fix, instead of removing the line in Default Applications: application/octet-stream=bliss.desktop I changed it to: application/octet-stream=gedit.desktop
    – dmuir
    Oct 21 '11 at 4:47
11

modify ~/.local/share/applications/mimeapps.list

[Default Applications] 
- text/plain=bless.desktop
- application/octet-stream=bless.desktop
+ application/octet-stream=gedit.desktop

This reverts the text/plain app to using the system default in /usr/share/applications/defaults.list, and changes the default application/octet-stream. It seems that Firefox labels this mime-type as "Unknown".

1
  • Is it only possible to set these defaults with a .desktop file and not a general path to the selected program ?
    – Atralb
    May 28 '20 at 4:29
2

right click on the unknown file, properties, open with. If your desired application is in the list, click on it, if not then click on the Show Other Applications and select the one you want. Cheers!

0

On Fedora using KDE, I went to:

System Settings -> Applications -> File Associations -> search for "plain"

"Text - Plain", then set your preferred program. This worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.