0

After installing Ubuntu 12.04 LTS in my laptop HP ProBook 855 G2, I found that my wireless network wasn't working. I noticed many people had the same problem, all of them having the same card RealTek RTL8723be (it shows as b723 with lspci). I already tried the following suggestion:

  1. Pull the repository at https://github.com/lwfinger/rtlwifi_new from a working computer and copy it to a USB stick.
  2. In the computer to be fixed, load stick and cd to folder. Then run:

    make
    sudo make install
    sudo modprobe rtl8723be
    
  3. At this point, the wireless network will be enabled, but it won't find any APs to connect with. I have tried tweaking the driver options as suggested in many places:

    echo "options rtl8723 ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf
    

But this didn't work. Any suggestions? Thanks.

  • Update question precisely with your kernel version and loaded modules – user3417815 Jul 18 '15 at 23:53
1

After searching further, the solution for my laptop in particular was to put the option msi=1 in the rtl8723be.conf file. Just to summarize the whole steps:

  1. Pull the repository at https://github.com/lwfinger/rtlwifi_new from a working computer and copy it to a USB stick.
  2. In the computer to be fixed, load stick and cd to folder. Then run:

    make 
    sudo make install 
    sudo modprobe rtl8723be
    
  3. At this point, the wireless network will be enabled, but it won't find any APs to connect with. Adding msi=1 to rtl8723be.conf fixed this problem:

    echo "options rtl8723 msi=1" | sudo tee /etc/modprobe.d/rtl8723be.conf
    

I guess different laptop models need different driver parameters, even though the wireless card is the same.

Note: the driver may break after some software upgrades, in which case just repeat step 2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.