1

So, I'm trying to auto-mount a Windows partition at startup. This is the line that I added in the fstab file:

UUID=4462435862434E3C /boot ntfs defaults,user 0 2

I read this tutorial and couple of other posts on SO, so it seems like the configuration I wrote is correct but, upon loading my Ubuntu, the partition is gone. I cannot see it in the window manager.

I also tried having just defaults for the <options> section, without user, but still the same effect.

Any suggestions?

Update:

I went along with Pilot6's solution, but used /media/my_username instead of /media/data or /media/user/my_username since both of the last 2 suggestion were causing error at system boot.

0

First of all do not mount partitions to /boot. That is fundamentally wrong. It may get your system unworkable.

To see partitions in your file manager you need to mount them to sub-directories of /media

The line should look like

UUID=4462435862434E3C /media/Data  ntfs-3g  defaults,windows_names,locale=en_US.utf8  0 0

You will also need to change the “locale=en_US.utf8” option to one suitable for your location and language if you are not in the USA. You can determine your locale with this terminal command

locale

You may also need to change ownership of the mount point to your user by running.

 sudo chown $USER:$USER /media/Data

or another mount point to give access to partition contents.

| improve this answer | |
  • Ok, I see. Just one question - the partition is located in the directory /media/my_username, but not in /media/data. When I write it, should I change it to my case or it should stay as you described it - /media/data? If is should be .../data then can you please elaborate why? – Milkncookiez Jul 18 '15 at 21:26
  • 1
    When you click a partition it is automatically mount to /media/user/some_name. But you can choose another directory when you set it up in fstab. It does not make much difference. – Pilot6 Jul 18 '15 at 21:28
  • Well, which would be the "most correct" way? – Milkncookiez Jul 18 '15 at 21:29
  • 1
    It's up to you to choose. Just do it with "user", if you need an advice. – Pilot6 Jul 18 '15 at 21:31
  • I have mounted the partition by clicking on it and then I ran the command df -T and the partition is mounted at /media/my_username, so I think I will go along with that one. – Milkncookiez Jul 18 '15 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.