I have installed the virtualbox from the oracle site not with my ubuntu 14.04 repository.

I've already downloaded the virtualbox guest additions that match my current virtualbox which is 5.0 from the oracle site.

Here are the steps that i followed to install the virtualbox guest additions. I did these steps in the host machine.

  1. sudo mnt -o loop ~/Downloads/VBoxGuestAdditions_5.0.0.iso /mnt
  2. cd /mnt
  3. sudo sh VBoxGuestAdditions_5.0.0.iso

But whenever i run homestead up, it shows that my virtualbox and virtualbox-guest-additions's version doesn't match.

This is the output whenever i run homestead up.

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Checking if box 'laravel/homestead' is up to date...
==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 80 => 8000 (adapter 1)
    default: 443 => 44300 (adapter 1)
    default: 3306 => 33060 (adapter 1)
    default: 5432 => 54320 (adapter 1)
    default: 22 => 2222 (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address:
    default: SSH username: vagrant
    default: SSH auth method: private key
    default: Warning: Connection timeout. Retrying...
    default: Warning: Connection timeout. Retrying...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
    default: The guest additions on this VM do not match the installed version of
    default: VirtualBox! In most cases this is fine, but in rare cases it can
    default: prevent things such as shared folders from working properly. If you see
    default: shared folder errors, please make sure the guest additions within the
    default: virtual machine match the version of VirtualBox you have installed on
    default: your host and reload your VM.
    default: Guest Additions Version: 4.3.14
    default: VirtualBox Version: 5.0
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Mounting shared folders...
    default: /vagrant => /home/chanhxc/.composer/vendor/laravel/homestead
    default: /home/vagrant/Codes => /home/chanhxc/Codes
==> default: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> default: flag to force provisioning. Provisioners marked to run always will still run.

I wonder what could be the problem.


Try to add this plugin from the terminal:

sudo vagrant plugin install vagrant-vbguest

After installed and you do the 'vagrant up' it will detect the version between host and guest. If version doesn't match then it update the guest additions version accordingly. Hope it helps. ;)

  • 3
    install this, homestead halt then homestead up and you should see it will keep the guest additions up to date from now on +1! – daviestar Aug 15 '16 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.