0

I just recently started using Ubuntu and have run into the first problem that I have not been able to solve with a few hours of web browsing so I thought I would ask here.

I'm currently experiencing the 14.04 login loop that other users have been reporting on these forums. To summarize the problem: After getting to the Ubuntu login screen and typing in my password, my PC briefly (for less than a second or two) looks like it's going to log in, but then just takes me back to the login screen. The guest account works fine though and lets me log in without a problem. Additionally, I am using an AMD R9 270x which may be the cause of the loop (looking into that).

Now I know that this has been reported by several other users, and I have tried a few of the solutions presented, but it was while trying another solution today that I ran into something interesting.

Using Ctrl + Alt + F2 to get to the terminal I was hoping to follow the instructions provided here. I made it to the section where I was supposed to enter

ls -ld ~/.*authority

and was met with the following error:

ls: cannot access /home/username/.*authority: no such file or directory

My question is twofold: Can I fix this and if so where should I look on how to fix this?

On a possibly related note, whenever I access the terminal via the method above I always notice the following lines:

[ 84.456557] Mount of device (uid: 1090) not owned by requested user (uid: 1000)

[ 84.456611] Reading sb failed; rc = [-1]

mount: Operation not permitted

I am not sure if this is contributing to the error message above, or if this is a separate issue (or a non-issue).

It should be noted that a complete reinstall of Ubuntu is an option for me, but I'd rather learn to fix this problem.

P.S. apologies for any poor formatting, writing this on a tablet sucks (I miss Ctrl + C and Ctrl + V).

EDIT: Found a solution here: 14.04: login loops back on itself - ecryptfs

  • Did you choose an encrypted home directory during the install? what is the result of plain ls -a after logging in at the Ctrl-Alt-F2 terminal? – steeldriver Jul 17 '15 at 20:10
  • I did choose to encrypt. ls -a gives me: . .. Access-Your-Private-Data.desktop .ecryptfs .Private README.txt – K G Jul 17 '15 at 20:12
  • I think the issue is probably that your encrypted home directory's ownership UID doesn't match your user UID, and that it will be fairly straightforward to fix (although hard to understand how it happened). I don't use encryption though so let's wait for someone more knowledgeable to chime in. – steeldriver Jul 17 '15 at 20:21
  • Thanks for the suggesting the encryption as a possible problem. I was able to find a solution here : askubuntu.com/questions/561455/… – K G Jul 20 '15 at 18:26
0

May be a problem with the graphics hardware...

Try the solutions described in the following link:

14.04 Freeze on Splash after Installing NVIDIA Drivers

Hope this help.

  • Although I am using an AMD card and that appears to be for Nvidia, I'll look into it. Thanks. – K G Jul 17 '15 at 20:07
  • So you may try this solution here: link . – Gabs Jul 17 '15 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.