3

So I installed intellij idea. The installer does not create a desktop icon (...) and further more, when I try deploying my files to my xampp (lampp) installation, I get an error. I guess this is due to permission denied.

So I read on a intellij installation site, to start intellij as root user. This is a bit confusing, is this acutally a really good idea? It can deploy the files now, but well, the app has root privileges.

if starting as root is normal, how do I create a desktop entry for my intellij?

3 Answers 3

3
  1. Download the latest version from here

  2. Extract the archive, eg. version 14.1.4

    tar xf ideaIC-14.1.4.tar.gz
    
  3. Move the archive and rename the folder

    sudo mv idea-IC-141.1532.4 /opt
    sudo mv /opt/idea-IC-141.1532.4 /opt/idea-IC
    
  4. Start IntelliJ to configure and create a desktop entry

    enter image description here

    enter image description here

  5. If there is no desktop entry, restart Unity and test is again

    The jetbrains-idea-ce.desktop file is placed in /usr/share/applications/ or in ~/.local/share/applications/

  6. If not, create your own desktop file

    nano ~/.local/share/applications/jetbrains-idea-ce.desktop
    

    with this content

    [Desktop Entry]
    Version=1.0
    Type=Application
    Name=IntelliJ IDEA Community Edition
    Icon=/opt/idea-IC/bin/idea.png
    Exec="/opt/idea-IC/bin/idea.sh" %f
    Comment=Develop with pleasure!
    Categories=Development;IDE;
    Terminal=false
    StartupWMClass=jetbrains-idea-ce
    
2
  • 1
    Aren't the desktop files created globally in /usr/share/applications not /usr/local/share/applications ?? Commented Nov 16, 2015 at 16:14
  • @DavidJFelix yes, you're right.
    – A.B.
    Commented Nov 16, 2015 at 16:25
2

Creating desktop entey for intellij is quite simple just go to just go to the intellij directory via the terminal then type: sh idea.sh. After it has loaded go to the Tools menu and select Create Desktop Entry. For permissions just go to the web directory via terminal and issue the command: sudo chmod -R 777, provide your root password and you will be good to go.

2

With the exception of administrative tasks, it's allmost never a good idea to run something as root. If your IDE can't write to where you need it to, the way to go is probably to fix permissions on that folder or subtree. E. g. if the target folder is writable for a certain group, the easiest way would be to add your everyday user to that group. Maybe you would have to first set group write permissions. But that might be unsafe for other reasons. Which permission settings to use depends strongly on your environment, so it's difficult to give you any advice with the information we have. Also, if you want someone to give you a hand with the desktop icon, please explain a little bit about your system (Gnome, KDE, XFCE...?).

4
  • unity I guess, whatever is standard for ubuntu 15.04. I think it's unity
    – Toskan
    Commented Jul 16, 2015 at 21:27
  • xampp installs itself with root:root privileges. So yeah, i can add my user to group root, but well. You know..
    – Toskan
    Commented Jul 16, 2015 at 21:29
  • The docroot is owned by root:root in xampp? That's the default? Okayyy... does that mean the web server is run by root? Isn't that highly unusal? Apache on Ubuntu usually runs as www-data.
    – Hinz
    Commented Jul 16, 2015 at 22:04
  • Unity is default. Afaik Unity doesn't have such a concept as desktop icons (correct me if I'm wrong, I don' use it). You can press the Windows key to get the dash, there you should find an icon for your IDE. If not start it on the commandline. After that you should see an icon in the starter bar (or whatever it's called) to the left. It should have a context menue that will allow you to promote it to a permanent starter.
    – Hinz
    Commented Jul 16, 2015 at 22:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .