123

I have the ISO image file (that is, *.iso) and I am trying to boot my VirtualBox installation with this image. Is it possible? I know how to mount my ISO image to my filesystem (on my host machine), but I don't think VirtualBox boots an OS from a location on my file system.

I've even tried to mimic mounting, such that VirtualBox thinks it has to boot from the CD drive, but this failed.

What is the correct way to boot an OS from an ISO image in VirtualBox?

My host machine is Ubuntu 10.04 (Lucid Lynx) and my VirtualBox version is 4.1.4.

  • Thanks! this really made things a lot simpler for me. I thought I would have to burn a DVD to load Kali linux. Saved me some $$$!!! – Matt Apr 21 '14 at 19:53
197

I would venture to say you are overcomplicating things! You only need to mount the iso in the virtual machine.

  1. Right click on the VM you want to run the .iso in
  2. Click on 'Storage' (On Oracle VM virtualBox, Click on 'Settings' first to get to 'Storage')
  3. Under IDE Controller There should be an icon that shows a CD with a + sign on it, to create a new disc drive as shown highlighted in yellow color in the below snapshot:

    Ubuntu - Settings, Storage menu

  4. A box will come up, click Choose Disk

  5. Choose your .iso

Should boot into the iso like it's in the disc drive.

  • 1
    I get the following error: paste.ubuntu.com/704782 – deostroll Oct 9 '11 at 8:45
  • 1
    @deostroll are you sure the file has the correct format and has not, e.g., been corrupted in download? What does the command file output if you run it on you .iso? – Riccardo Murri Oct 9 '11 at 11:39
  • 1
    @deostroll I also got an error when trying to add the iso as a disk. I just had to select "Add CD/DVD device" instead of "Add Hard Disk." – Brian Dec 1 '13 at 17:58
  • if I am using this method, I won't have the guestadditions, right ? I have images from yocto (iso, etc), and not sure how to install them on virtualbox. – ransh Feb 24 '17 at 4:19

protected by Community Apr 21 '14 at 19:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.