I've got an MSI Wind, model U100 that's been running Ubuntu without trouble for a long while. After upgrading to 10.04 a few months ago, I've had this strange problem. As soon as I unplug the laptop from the power source I get the warning dialog telling me that my battery is critically low, and the laptop suspends, regardless of what the battery level actually is. If I then turn the laptop back on, it runs fine and shows the correct battery level.

I've been working around this by manually suspending before switching to battery power, but I'm wondering if anyone else knows the cause or a fix.

  • Is your BIOS fully up to date? If you need do to update it, it's probably best to do so in Windows as that's what the updater is written for and it's not the sort of thing you really want to mess around with in Ubuntu. msi.com/…
    – user2405
    Oct 12, 2010 at 17:45
  • Are you using Gnome or KDE?
    – txwikinger
    Oct 12, 2010 at 18:22

2 Answers 2


I think this thread talks about this issue.

There's also a bug report on Lanchpad that may apply. See comment #4.

As a kludgy work-around, I turned off auto-hybernate by putting the following command into my /etc/rc.local file.

gconftool-2 --type bool --set /apps/gnome-power-manager/general/use_time_for_policy false

On the downside, if I forget to plug in my computer it just dies after the battery is spent.

  • Aha! That bug report is exactly my issue, and I'll try the workarounds contained therein. Hopefully this'll be fixed in 10.10. Nov 1, 2010 at 17:22

This is still an issue in 11.10 (beta 2 with kernel 3.0.0-12-generic) but the location has moved. See this post to fix for 11.10.

Where do I set use_time_for_policy?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.